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1. Purpose  
 

The Purpose of CFD Lab 3 is to simulate turbulent flows inside a diffuser following the “CFD 

process” by an interactive step-by-step approach and conduct verifications. Students will have 

“hands-on” experiences using ANSYS to conduct validation of velocity, turbulent kinetic 

energy, and skin friction factor. Effect of turbulent models will be investigated, with/without 

separations. Students will manually generate meshes, solve the problem and use post-processing 

tools (contours, velocity vectors, and streamlines) to visualize the flow field. Students will analyze 

the differences between CFD and EFD and present results in a CFD Lab report. 
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2. Simulation Design 

 
The problem to be solved is that of turbulent flows inside an asymmetric diffuser (2D). Reynolds 

number is 17,000 based on inlet velocity and inlet dimension (D1). The following figure shows 

what the geometry looks like with definitions for all geometry parameters. Before the diffuser, a 

straight channel was used for generating fully developed channel flow at the diffuser inlet. You 

will conduct simulation for two different half angles of 4 and 10 with two different turbulence 

models of SST and k-ε.  

 

 
Table 1 – Main particulars 

Parameter Symbol Unit Value 

Inlet dimension D1 m 2 

Inlet length L1 m 60 

Diffuser half angle α degree 4 or 10 

Outlet dimension D2 m 9.4 

Outlet length L2 m 70 

 

 

 

 
 

 

In CFD Lab3, all EFD data for turbulent airfoil flow in this Lab can be found on the class website 

http://www.engineering.uiowa.edu/~me_160/.  
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3. Starting with ANSYS Workbench 

 
3.1. Create the layout as per below. 

 

 

 

3.2  File > Save. Save the project on the network drive and Call it “CFD Lab 3”. 
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4. Geometry Creation 

 
In this section, we will create the geometry for the diffuser with 10 degree half angle, then copy 

and modify the geometry for the 4 degree half angled diffuser. 

 

 

4.1 Right click Geometry and select New DesignModeler Geometry… 

 

 
 

 

4.2 Make sure that Unit is set to Meter and Degree (default value). 
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4.3 Select XYplane and click New Sketch button. 

 

 

4.4 Right click Sketch1 and select Look at.  
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4.5 Sketching > Constraints > Auto Constraints. Enable the auto constraints option to pick the 

exact point as below.  
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4.6 Sketching > Draw > Line. Draw a vertical line on the y-axis starting from the origin as shown 

below (P indicates that the origin point is selected and V indicates that the line is vertical). 
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4.7 Sketching > Dimensions > General. Click on the vertical line then click on the left side of the 

line to place the dimension. Change the dimension in Details View to 2m (skip the unit ([m]) 

when put in the value). 
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4.8 Sketching > Draw > Line. Create a horizontal line on the x-axis starting at the origin as per 

below (H indicates that line is horizontal). 

 

 

4.9 Sketching > Dimensions > General. Change the length of the horizontal line you created to 

60m. 

 

 

4.10  Sketching > Draw > Line. Create line at an angle with respect to x-axis as shown below. 

 

4.11  Sketching > Dimensions > Angle. Select the line just created then select the x-axis then 

change the angle to 10°. (Note: if ANSYS gives a default exterior angle instead of the interior 

angle, right click and select Alternate Angle.) 
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4.12  Sketching > Draw > Line. Create a horizontal line as per below. 

 
 

4.13  Sketching > Dimensions > General. Change the length of the line just created to 70m. 

 

 

4.14  Sketching > Draw > Line. Draw the horizontal line circled in red line as per below. 

 

 

4.15  Sketching > Constraints > Equal Length. Select two lines circled in red as shown below. 
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4.16  Sketching > Draw > Line. Draw the horizontal line circled in red as per below. 

 

 

4.17  Sketching > Constraints > Equal Distance. Click on Point 1 and then click on the Point 2. 

Click Point 3 and then click on line 4. This makes points 1 and 3 the same distance from the 

y-axis in the horizontal direction. 

 

 

4.18  Sketching > Draw > Line. Draw the horizontal line circled in red as shown below. 

 

 

4.19  Sketching > Constraints > Equal Length. Click on two lines circled in red as below. 

 

 

 

 

 

 

1 2 

3 
4 
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4.20  Sketching > Draw > Line. Draw the final line circled in red as shown below. When you 

draw this line, if all previous dimensions and constraints are correct, the line should have two 

P’s at the ends with a V in the center. This indicates that the line starts and ends on the two 

points and is perfectly vertical. If you do not get the V, recheck all dimensions and constraints. 

 

 

4.21  Sketching > Dimensions > General. Change the length of the line circled in red to 9.4m, 

this will automatically adjust the length of the expansion region because of the applied 

constraints. 
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4.22  Concept > Surfaces From Sketches. Select the sketch you created and click Apply then 

click Generate. This will create a surface as shown below.  
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4.23  Tools > Face Split. Select the surface you created (it will be highlighted in green when 

you select it as shown below) then click Apply for Target Face. 

 

 

 

 

4.24  Click on the yellow region shown below. 
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4.25  While holding Ctrl button click on the two points circled in red then click Apply button. 

 

 

 

4.26  Click on the region marked with red rectangle below. 

 

 

4.27  While holding Ctrl button click on the two points circled in red then click Apply button. 
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4.28  Click the Generate button and Save your progress. 

 

 

4.29  Close the ANSYS Design Modeler and update geometry 

 
 

4.30  Right click on geometry and select Duplicate. 
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4.31  Rename the new geometry file as per below. 

 

 
 

 

4.32  Open the new geometry file you created and select Sketch1 under the tree outline as per 

below. Change the half angle to 4 degrees under details view as per below then click the 

Generate button. 

 
 

 

4.33  Save your file and quit ANSYS Design Modeler 
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5. Mesh Generation 

 
This section shows how to generate the mesh for both 4 degree and 10 degree half angle cases. 

 

 

5.1  Right click on Mesh and click Edit… 

 

 

 

5.2 Right click on Mesh then select Insert > Face Meshing. 
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5.3 Select all three surface while holding Ctrl button and click Apply located Geometry. 

 

 

 

5.4 Select the Edge button. This will allow you to select edges of your geometry. 

 

 

5.5 Right click on Mesh and Insert > Sizing. 
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5.6 While holding Ctrl, click on the edges shown below and click Apply. 

 

 

 

5.7 Change parameter for Edge Sizing as per below (Left edge is shown as an example). 
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5.8 Right click on Mesh and Insert > Sizing. 

 

5.9 While holding Ctrl, click on the edge shown below and click Apply. 

 

 

5.10  Change parameter for Edge Sizing as per below and click Apply (Right edge is shown as 

an example). 
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5.11  Right click on Mesh and Insert > Sizing. 

 

 

5.12  While holding Ctrl, click on the edge shown below and click Apply. 

 

 

5.13  Change parameter for Edge Sizing as per below and click Apply. 
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5.14  Right click on Mesh and Insert > Sizing. 

 

5.15  While holding Ctrl click on the edge shown below and click Apply. 

 

 

5.16  Change parameter for Edge Sizing as per below and click Apply. 
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5.17  Right click on Mesh and Insert > Sizing. 

 

5.18  While holding Ctrl click on the edge shown below and click Apply. 

 

 

5.19  Change parameter for Edge Sizing as per below and click Apply. 
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5.20  Mesh > Physics Preference. Change from Mechanical to CFD (Once you click the Mesh 

under the Outline, detailed options will appear as below). 

 
 

 

 

5.21  Click the Generate Mesh button. 
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5.22  Select Geometry to hide the mesh and click the Edge button. 

 

 
 

 

5.23  While holding the Ctrl button select the three top edges and right click on them, then select 

Create Named Selection. Change the name to top_wall and click OK. Similarly name the 

bottom_wall (bottom), inlet (left) and outlet(right). 
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5.24  File > Save Project and quit ANSYS Mesh. Right click on Mesh and click Update 

 

5.25  Repeat this process for 4 degree and 10 degree half angle cases. 

 

 

5.26  You should have the project schematic below. 
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6. Setup 

 
6.1  Right click Setup and click Edit. 

 

 

 

6.2  Check Double Precision and select START. 
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6.3  Tree > Setup > General > Mesh > Check. Set the parameters as per below.  

 

 

6.4  Tree > Setup > Models > Viscous. Select parameters as per below and click OK(Apply).  
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6.5  Tree > Setup > Materials > Fluid > air. Change the fluid properties and then click 

Change/Create then click Close.  

 

 

6.6  Tree > Setup > Boundary Conditions > Zone > inlet. Change parameters for inlet velocity. 

Use the table below for as per below and click OK(Apply). 

 

Inlet Boundary Condition 

Variable u (m/s) v (m/s) P (Pa) k (m^2/s^2) e(m^2/s^3) 

Magnitude 1.25 0 - 0.0018 9.63e-05 

Zero Gradient - - Y - - 
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6.7  Tree > Setup > Boundary Conditions > Zone > outlet. Change parameters as per below and 

click OK(Apply). 

 

Outlet Boundary Condition 

Variable u (m/s) v (m/s) P (Pa) Intensity (%) Length scale (m) 

Magnitude - - 0 3.25 0.0035 

Zero Gradient Y Y - - - 

 

6.8 Make sure boundary condition type is wall for top and bottom walls.

 

Wall Boundary Condition 

Variable u (m/s) v (m/s) P (Pa) k (m^2/s^2) e (m^2/s^3) 

Magnitude 0 0 - 0 0 

Zero Gradient - - Y - - 
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6.9  Tree > Setup > Reference Values. Change reference values as per below. 

 

 In case of ‘Yplus for Heat Tran. Coef’ leave it as a default value (300) 

 

6.10  Tree > Solution > Methods. Change the solution methods as per below. 
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6.11  Tree > Solution > Monitors > Residual. Change convergence criterions to 1e-05 and 

click OK(Apply). 

 

6.12  Tree > Solution > Initialization. Change parameters as per below and click Initialize.  
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6.13  Tree > Solution > Run Calculation. Change Number of Iterations to 10,000 and click 

Calculate. 

 

 

 

 

6.14  Save your project and quit ANSYS fluent. 
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6.15  Duplicate the k-e setup for 10 degree half angle case to 4 degree angle case as per below 

then run the case. You need to make new connection between 4 degree case’s mesh and 

duplicated setup. Once you enter the new setup, initialize first and then run. 

 
 

      After simulation runs 
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6.16  Duplicate the k-e setup for 10 degree half angle and rename it as SST 

 
 

 

6.17  Right click and select Edit…. 
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6.18  Tree > Setup > Models > Viscous. Select SST model and use the default parameters as per 

below then click ok(Apply). 

  
 

 

6.19  Tree > Solution > Controls. Change Under-Relaxation Factors as per below. 
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6.20  Tree > Solution > Initialization > Initialize. 

 

 

6.21  Tree > Solution > Run Calculation > Calculate.    

   After finish the calculation, File > Save Project.  Then Close the window 

 

 

6.22  Duplicate SST fluent setup for the 4 degree half angle case and run the simulation as per 

below (You should initialize before running the case). 
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7. Results (Read exercises (Section 8) before continuing.)  
 

7.1 Creating lines for modified TKE and modified U plots. 

Setting Up Domain > Surface > Create > Line/Rake. Create 7 lines at the given location on 

the table. 

 

 

 

 

Surface Name  x0 y0 x1 y1 

Position-1 78 -3.52 78 2 

Position-2 82 -4.23 82 2 

Position-3 86 -4.9371 86 2 

Position-4 98 -7.053 98 2 

Position-5 102 -7.4 102 2 

Position-6 110 -7.4 110 2 

Position-7 118.5 -7.4 118.5 2 



40 

 

7.2 Defining custom field functions for modified U, modified TKE and skin friction coefficient. 

User-Defined > Custom. Write the equation shown below and click Define. You will need 

to look up the Field function and the buttons to enter the parameters in the Definition. 

Definitions of the variables and custom field function that need to be defined are shown on 

table below.  

 

 

 

Function Name Definition 

u*10+x (Modified U) 10*Vx+x-60 

k*500+x (Modified TKE) 500*turb-kinetic-energy+x-60 

skinfriction-coefficient x-wall-shear * 2 / density / 1.25 ^ 2 
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7.3 Plotting modified U and modified TKE 

 

Instruction for plotting modified U is given here. The only difference between modified U 

and modified TKE plot is a different “X-axis function”. 

 

Results > Plots > XY Plot > Set Up… > Load File… Select the ‘Modified_u-10degree.xy’ 

file downloaded from the class website and click OK  

Note : Make sure about options as shown below. 

Turn off “Position on X Axis” and Turn on “Position on Y Axis” 

 

You can compare EFD and CFD using the customizing functions (Curves…) on the lines 

you created as per below. Be careful about the axis location as shown below 

 

7.4  Plotting skin friction coefficient 

 



42 

 

Results > Plots > XY Plot > Load File… Select the ‘Skin_Friction_bot_wall.xy’ file 

downloaded from the class website and click OK. 

Change the parameters as per below and click Plot. 

 
 

You can change the axis by clicking Axes… under XY plot. Change the x-axis min and max 

to 60 and 130 respectively (uncheck Auto Range) and click Apply. Change the y-axis max 

and min to 4e-03 and -1e-03 respectively. Click Apply and click Plot again. 
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7.5 Total friction 

 

Results > Reports > Forces. Select the zone where you want to calculate the total force 

then select print. This will print a report as per below 
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7.6 Finding the pressure difference between inlet and outlet.  

 

You can simply write pressure at bottom wall to a file and take the difference of pressure at 

inlet and outlet. 
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7.7 Plotting contours, velocity vectors and streamlines. 

 

Refer to previous manuals for lab 1 and 2 for plotting streams, velocity vectors and pressure 

distributions. You can change the scales and levels for vectors and streamlines respectively to 

show the separation region. Few examples are shown at below. 
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8. Data Analysis and Discussion 
 

8.1  Simulation of turbulent diffuser flows without separation (4 degree) (+20) 

 
8.1.1 Run simulations for 4 degree half angle diffuser with k-ε model. 

8.1.2 Run simulations for 4 degree half angle diffuser with SST model. 

8.1.3 Questions:  

 Do you observe separations in 8.1.1 or 8.1.2? (use streamlines) 

 What are the differences between 8.1.1 and 8.1.2 regarding modified u, modified TKE, and 

the variables in the following table? 

Turbulent model 
Total pressure difference 

between inlet and outlet (Pa) 

Total friction force on the 

upper wall (N) 

SST   

k-e   

Relative error (%)   

 

 Figures need to be reported (for both 8.1.1 and 8.1.2):  

(1) Residual history (2) Modified u vs. x (3) Modified TKE vs. x (4) Contour of pressure  

(5) Contour of axial velocity (6) Velocity vectors and streamlines 

 Data need to be reported: the above table with values. 

 
8.2  Simulation of turbulent diffuser flows with separation (10 degree) (+22):  

 
8.2.1 Run simulations for 10 degree half angle diffuser with k-ε model. 

8.2.2 Run simulations for 10 degree half angle diffuser with SST model. 

8.2.3 Questions: 

 Do you observe separations in 8.2.1 or 8.2.2? (using streamlines) 

 Comparing with EFD data, what are the differences between 8.2.1 and 8.2.2 on the following 

aspects: (1) Modified velocity (2) Modified TKE (3) Skin friction factor on top and bottom 

walls (4) Variables in the following table. 

Turbulent models 
Total pressure difference 

between inlet and outlet (Pa) 

Total friction force on the 

upper wall (N) 

SST   

k-e   

Relative error (%)   

 If any separation shown, where is the separation point on the diffuser bottom wall (x=?) and 

where does the flow reattach to the diffuser bottom wall again (x=?) (use wall friction factor) 

 Do you find any separation on the top wall? 

 

 Figures need to be reported (for both 8.2.1 and 8.2.2):  

(1) Residual history (2) Modified u vs. x with EFD data (3) Modified TKE vs. x with EFD 

data (4) Skin friction factor distributions on top and bottom walls with EFD data (5) Contour 

of pressure (6) Contour of axial velocity (7) Velocity vectors and streamlines with appropriate 

scales showing the separation region if the simulation shows separated flows. 

 Data need to be reported: The above table with values. 
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8.3  Questions need to be answered in CFD Lab3 report 

 
8.3.1 Questions in exercises 8.1-8.2.  

8.3.2 By analyzing the results from exercise 1 and exercise 2, what can be concluded about the 

capability of k- ε and SST models to simulate turbulent flows inside a diffuser with and 

without separations? (+3) 
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9. Grading scheme for CFD Lab Report  

(Applied to all CFD Lab reports) 

 
Section                          Points 
 

1                 Title Page                                                                                                                    5 

                   1.1 Course Name 
                   1.2 Title of report 

                   1.3 Submitted to “Instructor’s name” 

                   1.4 Your name (with email address) 
                   1.5 Your affiliation (group, section, department) 

                   1.6 Date and time lab conducted 

2                 Test and Simulation Design                        10 

                   Purpose of CFD simulation  
3                 CFD Process                    20 

                   Describe in your own words how you implemented CFD process  

                   (Hint: CFD process block diagram) 
4                 Data Analysis and Discussion Section 8 (Page# 47) for CFD Lab 3                    45 

                   Answer questions given in Exercises of the CFD lab handouts 

5                 Conclusions                        20 
                   Conclusions regarding achieving purpose of simulation 

                   Describe what you learned from CFD 

                   Describe the “hands-on” part 

                   Describe future work and any improvements  
                                                                                                                                               Total   100 

 

 
Additional Instructions: 

 

1. Each student is required to hand in individual lab report.  

2. Conventions for graphical presentation (CFD): 
               * Color print of figures recommended but not required 

       3. Reports will not be graded unless section 1 is included and complete 

 


	Simulation of Turbulent Flow in an Asymmetric Diffuser
	ME:5160 Intermediate Mechanics of Fluids
	CFD LAB 3
	(ANSYS 2022 R1; Last Updated: July 19, 2022)
	7.1 Creating lines for modified TKE and modified U plots.
	Setting Up Domain > Surface > Create > Line/Rake. Create 7 lines at the given location on the table.
	7.2 Defining custom field functions for modified U, modified TKE and skin friction coefficient.
	User-Defined > Custom. Write the equation shown below and click Define. You will need to look up the Field function and the buttons to enter the parameters in the Definition. Definitions of the variables and custom field function that need to be defin...
	7.3 Plotting modified U and modified TKE
	Instruction for plotting modified U is given here. The only difference between modified U and modified TKE plot is a different “X-axis function”.
	Results > Plots > XY Plot > Set Up… > Load File… Select the ‘Modified_u-10degree.xy’ file downloaded from the class website and click OK
	Note : Make sure about options as shown below.
	Turn off “Position on X Axis” and Turn on “Position on Y Axis”
	You can compare EFD and CFD using the customizing functions (Curves…) on the lines you created as per below. Be careful about the axis location as shown below
	7.4  Plotting skin friction coefficient
	Results > Plots > XY Plot > Load File… Select the ‘Skin_Friction_bot_wall.xy’ file downloaded from the class website and click OK.
	Change the parameters as per below and click Plot.
	You can change the axis by clicking Axes… under XY plot. Change the x-axis min and max to 60 and 130 respectively (uncheck Auto Range) and click Apply. Change the y-axis max and min to 4e-03 and -1e-03 respectively. Click Apply and click Plot again.
	7.5 Total friction
	Results > Reports > Forces. Select the zone where you want to calculate the total force then select print. This will print a report as per below
	7.6 Finding the pressure difference between inlet and outlet.
	You can simply write pressure at bottom wall to a file and take the difference of pressure at inlet and outlet.
	7.7 Plotting contours, velocity vectors and streamlines.
	Refer to previous manuals for lab 1 and 2 for plotting streams, velocity vectors and pressure distributions. You can change the scales and levels for vectors and streamlines respectively to show the separation region. Few examples are shown at below.
	8. Data Analysis and Discussion

	9. Grading scheme for CFD Lab Report
	(Applied to all CFD Lab reports)


