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1. Purpose

The Purpose of CFD Lab 2 is to conduct parametric studies for turbulent flow around Clarky airfoil
following the “CFD process” by an interactive step-by-step approach. Students will have “hands-on”
experiences using ANSYS to investigate the effect of angle of attack and effect of different turbulence
models on the simulations results. These effects will be studied by comparing simulation results with EFD
data. Students will analyze the differences and possible numerical errors, and present results in Lab report

Geometry Physics > Mesh Solution Results
Airfoil (ANSYS General (ANSYS Structured Solution Plots (ANSYS
Design Modeler) Fluent - Setup) (ANSYS Mesh) Methods Fluent- Results)

_ (ANSYS Fluent -
O-Domain Model (ANSYS .
i Solution) .
(ANSYS Design Fluent - Setup) Graphics and
Modeler) - Animations
Boun_d_ary Solution Controls (ANSYS Fluent-
Conditions (ANSYS Fluent - Results)
(ANSYS Fluent - Solution)
Setup)
Monitors
Reference Values (ANSY'S Fluent -
(ANSYS Fluent - Solution)
Setup)
Turbulent Solution
Solution Initialization
Initialization (ANSY'S Fluent -
(ANSYS Fluent - Solution)
Solution) -
Run Calculation
(ANSYS Fluent -
Solution)

Flow chart for “CFD Process” for airfoil flow




2. Simulation Design

In EFD Lab 3, you have conducted experimental study for turbulent airfoil flow around a ClakY airfoil
(Rex~300,000). The data you have measured were used for CFD PreLab 2. In CFD Lab 2, simulation will be
conducted under the same conditions of EFD Lab 3, except angle of attack and turbulent models that will be
changed in this lab.The problem to be solved is turbulent flow around the ClarkY airfoil with angle of attack

CY)

Table 1 - Geometry dimensions

Parameters Symbol Unit Value
Chord Length C m 0.3048
Domain radius Rc m 12
Angle of attack o m 16

Figure 1 — Geometry



3. Open ANSYS Workbench
3.1. Start > All Programs > ANSYS 16.2 > Workbench 16.2
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3.2. From the ANSYS Workbench home screen (Project Schematic), drag and drop a Geometry, Mesh,
and two Fluent component from the Component Systems drop down menu onto the Project
Schematic. Project Schematic should resemble the schematic below. Rename the components as
per below.

J\ Unsaved Project - Workbench i i_ [E= )

File  View Tools Units Extensions Help

I New [5 Open... |l save ESE\!’E As... |ﬂ]1mport... «¢Reconnect 2 Refresh Project Update Project | €3 Project 0CompactMode

fz Transient Structural -
E Transient Thermal

|EI Component Systems |
@ Autodyn

[} CFX

I g Engineering Data

F Bxternal Connection

External Data

(i@ Finite ElementModeler

Create standalone system

Fluent i i
Fluent {(with TGrid meshing)
|3 Geometry
# ICEM CFD
II I\ Mechanical APDL 1
i ﬁ Mechanical Model 3
@ Mesh 1
% Microsoft OfficeExcel
=2 Polyflow
=2 Polyflow-Blow Molding =
=2 Polyflow-Extrusion
) Results -
I | T view All j Customize. ..
Messages IA Progress] \
o Ready [ Show Progress ][L.',LlShow4Messages .
L - E__ -




s
I\ Unsaved Project - Workbench —— e - E‘@g
- e

Fle View Tools Units Extensions Help

|_‘] New ﬁopen... & save Esave As... |ﬁj1mport. ‘ «9Reconnect @ Refresh Project  + Update Project | @ Project OCompact Mode

l 1] Magnetostatic -
ﬂ_i Modal
fili Random Vibration - A = E = <
£l Rigid Dynamics 2 @ Geometry v ,————@2 @ Mesh &, 2 @ setp Ty
[ seatic Siructural CFD Lab 2 Turbulent Flow Rirfoil O-Mesh 3| @@ soition P

ﬂ Steady-State Thermal
Thermal-Electric Kee
% Transient Structural |
ﬂ Transient Thermal
|E Component Systems

- D

@ Engineering Data 2 e Setp
o Bdternal Connection 3 | @@ soltien 7
External Data K-w

Finite ElementModeler
Fluent

Fluent {with TGrid meshing)
Geometry

ICEM CFD

Mechanical APDL
Mechanical Model

Mesh

Microsoft OfficeExcel
Polyflow L&
Polyflow- Blow Molding
Polyflow-Extrusion

@ Results 2

m

rHEes>SAAEE

‘ T View All / Customize...

Messages

; Ready () Show Progress ||, Show 4 Messages | .:

3.3. Create a Folder on the H: Drive called CFD Lab 2.

3.4. Save the project file by clicking File > Save As...

3.5. Save the project onto the H: Drive in the folder you just created and name it CFD Lab 2 Turbulent
Flow.



4. Geometry
4.1. Right click Geometry then select Import Geometry > Browse... Select airfoil.igs and click OK.
Note: The airfoil geometry is found on the class website http://user.engineering.uiowa.edu/~fluids/
under the heading CFD PreLab2.
4.2. Right click Geometry and select Edit Geometry in DesignModeler...
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4.3. Click Generate.
4.4. Select Sketching > Constraints > Auto Constraints. Enable the auto constraints option to pick the
exact point as below
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http://user.engineering.uiowa.edu/%7Efluids/

4.5. Create > Body Transformation > Rotate. Select the airfoil and click Apply. Click the yellow box
labeled Axis Selection then click the XYPIlane in the Tree Outline, then click Apply. Change the
Angle to 16° and click Generate.
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4.6. Select XYPlane and click New Sketch button.
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4.7. Select the sketch you created and click sketching button.
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4.8. Sketching Toolbox > Draw > Circle. Click on the xy-plane origin and click behind the airfoil.

(Click z-arrow at rlght bottom to set the view as perpendicular to xy-plane)
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4.9. Sketching Toolboxes > Dimensions > General. Click on the circle and change the diameter to 12m.
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4.10. Concept > Surface From Sketches. Select Sketchl from the Tree Outline, click Apply, then
click the Generate button.
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4.11.
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Create > Boolean. Change operation to Subtract then select the circle for Target Bodies and
click Apply then select airfoil (click on the airfoil until only the airfoil’s color turns yellow) for Tool
Bodies and click Apply then click Generate. This will subtract the airfoil surface from the circle.
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4.12.

4.13.

4.14.

Concept > Split Edges. Select the perimeter of the circle and click Apply. Select Generate.
This should split the circle into two semicircles. You can see the semicircles by selecting the
perimeter above and below the x-axis.

Repeat the process from 4.11 on the two semicircles. This should yield four circular
quadrants.

Repeat this process for the arc in quadrant IV (lower right). Change the Fraction to 0.822222.
This splits the arc into a 16° and a 74° arc.
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4.15. Concept > Lines From Points. Draw a line from the point on the circle to the point on the
airfoil making sure to hold Ctrl while doing so. (Note: The point on the front part of the airfoil is not
exactly on the origin, you need to make sure to select the point on the airfoil and not the origin.
Zoom in and find the point just below the origin and select that point. The images below show the
locations of the points circled. When selecting points to generate lines with, be sure to select the
point on circle and then the point on the airfoil as to avoid complications when sizing mesh).

(oEE > e T b [BE T @ - ME [ SEARAREAAE el @
W M- 4~ A A A= A~ A =

| 2miny mesetng [
= "I
. .M""' LD
i Lines From Point Cresion - Sefect s of 20 o, 30 vt s et 1 Pasre Segrment Mew B #
4.16. Once you select both points click Apply, then click Generate.
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4.17. Repeat this process creating lines from the edge of the circle to the airfoil starting from the
circle and ending at the airfoil (A to A’, B to B” and C to C’). The images below show the locations
of the points on the airfoil and the points on the circle.
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4.18. Tools > Projections. Select the four lines you created for Edges and select the circle for
Target then click Generate. This will split your geometry into four sections
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4.19. Tools > Merge. Change the Merge Type to Edges. Select the 16° arc and the arc in quadrant
I and select Apply. Click Generate. This merges the lines into one line which can be sized for
meshing easier.

4.20. File > Save project and exit.
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5. Mesh Generation

5.1. From the Project Schematic right click on Mesh and select Edit... from the dropdown menu.
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5.2. Right click Mesh then Insert > Face Meshing. Select the four surfaces while then click Apply.
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5.3. Right click Mesh and Insert > Sizing. Select two edges as per below and change the parameters as
per below. You might need to change the cursor to “Edge selector” at this moment.
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L.

=I|5cope

Details of "Edge Sizing" - Sizing
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5.4. Right click Mesh and Insert > Sizing. Select two edges as per below and change the parameters as
per below.

Details of "Edge Sizing 2" - Sizing
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5.5. Right click Mesh and Insert > Sizing. Select all for lines leading from the circle to the airfoil

surface, and click Apply. Change parameters as per below. Note: If you did not create the lines

starting from the outer circle and ending on the airfoil surface, you may have issues with biasing. If
this is your case, size the lines individually making sure that the sizing is finest at the surface of the

airfoil.
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Details of "Edge Sizing 3" - Sizing
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5.6. Right click Mesh and Insert > Sizing. Select the surface at the top of leading edge of the airfoil and

click Apply. Change Parameters as per below.

Details of "Edge Sizing 4" - Sizing

EISmpe
Scoping Method Geometry Selection
Geometry 1 Edge
[=I} Definition
Suppressed Mo
Type Mumber of Divisions
Mumber of Divisions |45
Behavior Hard
Bias Type —— o _ _
Bias Option Bias Factor
Bias Factar 15,

5.7. Right click Mesh and Insert > Sizing. Select the surface at the bottom of leading edge of the airfoil
and click Apply. Change Parameters as per below.

Details of "Edge Sizing 5" - Sizing
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5.8. Right click Mesh and Insert > Sizing. Select the surface at the top of trailing edge of the airfoil and

click Apply. Change Parameters as per below.
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5.9. Right click Mesh and Insert > Sizing. Select the surface at the bottom of trailing edge of the airfoil
and click Apply. Change Parameters as per below.

Details of "Edge Sizing 7" - Sizing
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Scoping Method Geometry Selection
Geometry 1 Edge
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Suppressed Mo
Type Mumber of Divisions
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Behavior Hard
Bias Type o
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Bias Factor 15,
5.10. Click on Mesh under the Outline, under the Details of “Mesh”, change the Physics

Preference from Mechanical to CFD. This changes the grid solver to a fluids style solver rather

than a FEA style solver.

Details of "Mesh" a
|| Defaults
Physics Preference CFD b
Solver Preference Mechanical

Inflation

Electromagnetics
Relevance
| Sizing

[=]| Assembly Meshing

Method

|N0ne

[=|| Patch Conforming Options

Triangle Surface Mesher | Program Controlled

Advanced

Defeaturing

[+]| Statistics

5.11. Click Generate Mesh. Click on the Mesh button under the Outline and make sure it

resembles the mesh below.
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5.12. Hold Ctrl and select the two left most semicircle arcs, right click on them and select Create
Named Selection, name the selection inlet. Use the edge select button from the toolbar.
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5.13. Do the same for the two right most semicircle arcs and name them outlet.
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5.14. Select the four arcs that make the airfoil, right click and Create Named Selection and name it

airfoil.
ANSYS
R14.5
Academic
<} Generate Mesh On Selected Bodies
] Clear Generated Data On Selected Bodies
@ Hide Body
@ Hide Al Other Bodies
5.15. Now use the face button to select the four semicircle quadrants and Create Named Selection

and name them fluid.
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5.16. File > Save Project. Exit the window.
5.17. Right click Mesh and select Update from the dropdown menu.
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6. Setup (Physics)

6.1. From the Project Schematic right click on Setup and select Edit...
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6.2. Select Double Precision and click OK.
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6.3. Solution Setup > Models > Viscous —Laminar > Edit... Change the parameters as per below and
click OK. (For the k- case, you will select k-omega (2 egn).
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6.4. Solution Setup > Materials > air > Create/Edit... Change parameters as per experimental data and
click Change/Create.
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Use the air properties at the room temperature when you conducted EFD Lab3. You can use the following
website to calculate air properties from the temperature:
http://www.mhtl.uwaterloo.ca/old/onlinetools/airprop/airprop.htmi

The values in the figure above are for 24° temperature.
NOTE: viscosity used in ANSYS is the dynamic viscosity (kg/m-s), NOT kinematic viscosity (mz/s)
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6.5. Solution Setup > Boundary Conditions > inlet > Edit...

Change parameters as per experimental

data (blue box) and default values (red boxes) and click OK. The experimental value can be found

from the EFD Lab 3 data reduction sheet.
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6.6. Solution Setup > Boundary Conditions > Outlet > Edit... Change the parameters as per below

and click OK. (Use outlet B.C. for both k-g¢ and k-@ models)
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6.7. Solution Setup > Reference Values. Change parameters as per below. The Velocity, Temperature,
Density, and Viscosity should be entered from EFD data.
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7. Solution

7.1. Solution > Solution Methods. Change parameters as per below.

k-g
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7.2. Solution > Solution Controls. Change Parameters as per below. (If you have problems with the
solution converging, you can decrease the Under Relatlon Factors.)
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7.3. Solution > Monitors > Residuals —Print, Plot > Edit.... Change the convergence limit to 1e-05

for all five equations.
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7.4. Solution > Solution Initialization. Change the parameters as per below and click Initialize.
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7.5. Solution > Run Calculation. Change the Number of Iterations to 10000 and click Calculate.
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7.6. File > Save Project.
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8. Results

8.1. Plotting and Saving Residual History
Solution > Monitors > Residuals —Print, Plot > Edit... > Plot > Ok.

Cik-e Fluent@L-COF417-00.engin uiowa.edu [2d, dp, pbns, skw] [ANSYS Academic Teaching Advanced] I =

File Mesh Define Solve Adapt Surface Display Report Parallel View Help

Bs-H-mesEA’ e nm-O-in-E-Y 2 ATE

E Q Setup ‘ Monitors :
i General

Y Models

Materials

Cell Zone Conditions

Boundary Conditions

Dynamic Mesh
-4 Reference Values

= §8 Solution -
@ Solution Methods
Solution Controls Surface Monitors

=

Volume Monitors

[ Reports
| ®-&s Parameters & Customization

1000 1200 1400 1600 1800 2000
B Residual Monitors t o] [terations
Gptions Equations
Converd | | (7] print to Cansole | continity ‘ 1e-05 o
@plot v am—
Ll x-velodty 1e-05 ANSYS Fluent Release 16.2 (2d
Window
1 = y-velocity 1e-05 ; ;
= |Curves... || Axes... | k onega time/iter
- 1.0841e-05 4.9100e-06 0:05:12 8063
|| lEretns Ci]t k 1e-05 1.0795e-65 U4.8831e-06 0:31:02 8062
Convel | 1000 ® - 0 1.0749e-85 4.8647e-086 0:24:50 8661
omeaa 1 7 1e-05 1.8763e-B5 4.8338e-06  B:19:52 BE68
Residual Values Convergence Criterion 1.8657e-85 U4.813%e-86 B:15:53 BO59
Iterations o Store [ Normalize: R B - 1.8612e-85 4.7851e-06  6:12:42 8053
’710007@ - = 1.8567e-65 U4.7709e-06 0:10:16 8657
= E 1.0522e-85 U4.7888e-06 0:08:08 8056
] scok 1.8477e-85 14.7888e-06 0:06:38 BOSS
* 1.8433e-85 U4.7966e-86 0:05:12 BESH
[ Compute Local Scale 1.6389e-05 4.8638e-06 0:31:66 8053
k omega time/siter
| e | v | [ cancel | [ reb | 1.0345e-05 L.8036e-06 0:24:48 8052

1.8362e-85 4.8BB5e-86 B:19:58 8A51

File > Save Picture... > Save... Make sure the parametefs are as per below and click Save...
Name the file CFD Lab 2 Residual History change the file directory to the CFD Lab 2 file you
created on the H: drive and click OK.
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8.2. Plotting Pressure Coefficient Distribution with CFD and EFD Data
Results > Plots > XY Plot > Set Up... > Load File... Select Pressure-coef-attack16.xy. Change
the parameters as per below and click Plot. Save the picture the same way as you did for
Residual History but in this case, name it CFD Lab 2 Pressure Coefficient Distribution.
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8.3. Plotting Contour of Pressure
Results > Graphics > Contours > Set Up... Change the parameters as per below and click
Display. Save the picture the same way as you did for Residual History but in this case, name it
CFD Lab 2 Contour of Pressure.
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8.4. Plotting Contour of Velocity Magnitude
Results > Graphics and Animations > Contours > Set Up... Change the parameters as per
below and click Display. Save the picture the same way as you did for Residual History but in
this case, name it CFD Lab 2 Contour of Velocity Magnitude. Zoom in where you can see the
airfoil clearly and the change in contour levels around the airfoil.
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8.5. Plotting Velocity Vectors at Trailing Edge
Results > Graphics and Animations > Vectors > Set Up... Change parameters as per below
and click Display. Save the picture the same way as you did for Residual History but in this
case, name it CFD Lab 2 Vectors of Velocity at Trailing Edge. Zoom in on the trailing edge.
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8.6. Plotting Streamlines Close to Airfoil Surface
Results > Graphics and Animations > Contours > Set Up... Change parameters as per below
and click Display. Save the picture the same way as you did for Residual History but in this
case, name it CFD Lab 2 Streamlines Close to Surface.
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8.7. Printing Lift and Drag Coefficients

Results > Reports > Forces > Set Up... Change parameters as per below and click Print. This
prints out the drag force. If you change the X parameter to zero and the Y parameter to 1, this
prints out the lift force. Save the coefficients by clicking Write. This creates a text file of what
was printed on the screen. Name the file Drag Coefficient or Lift Coefficient.
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9. Exercises

Parametric Studies of Turbulent Flow around an Airfoil

e You must complete all the following assignments and present results in your CFD Lab 2 reports

following the CFD Lab Report Instructions.

e Use “CFD Lab2 Report Template.doc” to save the figures and data for each exercise below.

e Use the benchmark EFD data from the class website if your EFD Lab 3 data are with a
different angle of attack than 16 degrees.

1. Effect of angle of attack.
1.1. Use the same flow conditions as those in your EFD Lab 3, including geometry (chord length)
and setup (Flow properties, Reynolds number, inlet velocity), EXCEPT use angle of attack 16
Degrees regardless of AOA in you EFD Lab 3. Use k-g model, 2" order upwind scheme, double
precision with iteration number (2000) and convergent limit (10®).
e Figures need to be saved: 1. Time history of residuals (residual vs. iteration number); 2.
Pressure coefficient distribution (CFD and EFD), 3. Contour of pressure, 4.Velocity vectors, and 5.
Streamlines
e Data need to be saved: lift and drag coefficients

2. Effect of turbulence models

2.1. Use the same conditions as those in exercise 1, EXCEPT using the “k-o” for “viscous models”.

Set up the boundary conditions following instructions part, set the iteration number to be (2000), and

convergent limit to be 10°°. Perform the simulation and compare solutions with the simulation results

using “k-&” model (you have finished in CFD PrelLab?2)

e Figures need to be saved: 1. Time history of residuals (residual vs. iteration number); 2.
Pressure coefficient distribution (CFD and EFD), 3. Contour of pressure 4. Velocity vectors, and
5. Streamlines

e Data need to be saved: lift and drag coefficients

3. Questions need to be answered in CFD Lab2 report:
Using the figures obtained in exercises 1 and 2 in this Lab and those figures you created in CFD
PreLab2 to answer the following questions and present your answers in your CFD Lab 2 report.
Note: These questions are also available in the “CFD Lab2 Report Template” where you will type
answers.
3.1. For Exercise 1 (effect of angle of attack):
(1). Which angle of attack simulation requires more iterations to converge?
(2). Which angle of attack produces higher lift/drag coefficients? Why?
(3). What is the effect of angle of attack on lift and drag coefficients?
(4). Describe the differences of streamline distributions near the trailing edge of airfoil surface for
these two different angles of attack. Do you observe separations for both? If so, does the
separation occur at the same location?
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3.2. For Exercise 2 (different turbulence models):
(1). Do the two different turbulence models have the same convergence path? If not, which one
requires more iterations to converge.
(2). Do the two different turbulence models predict the same results? If not, which model predicts
more accurately by comparing with EFD data?
3.3. For the following contour plot, qualitatively compare the values of pressure and velocity
magnitude at point 1 and 2, if the flow is from left to right. Which location has higher pressure
and which location has higher velocity magnitude? Why?

3.4. Questions in CFD PreLab?2.
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