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1. Purpose 

The Purpose of CFD Lab 1 is to teach students how to use ANSYS, practice more options in each step of CFD Process, and relate simulation results to EFD and AFD concepts. Students will simulate turbulent pipe flow following the “CFD process” by an interactive step-by-step approach. The flow conditions will be the same as they used in EFD Lab2. Students will have “hands-on” experiences using ANSYS to compute axial velocity profile, centerline velocity, centerline pressure, and wall shear stress. Students will compare simulation results with their own EFD data, analyze the differences and possible numerical/experimental errors, and present results in a CFD Lab report.
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Flow chart for “CFD Process” for pipe flow
2. Simulation Design

In EFD Lab 2, you have conducted experimental study for turbulent pipe flow. The data you have measured include centerline pressure distribution and fully developed axial velocity profile. These data will be used in this Lab for comparisons with CFD predictions. 
The problem to be solved is that of turbulent flows through a circular pipe. Reynolds number based on pipe diameter and inlet velocity should be computed from your own EFD data and is much higher than the Reynolds number used in CFD Prelab1. 
Table 1 - Main particulars

	Parameter
	Unit
	Value

	Radius of Pipe
	m
	0.02619

	Diameter of Pipe
	m
	0.05238

	Length of the Pipe
	m
	6.096


         
[image: image2]
The problem formulation is similar to that in CFD PreLab1 and will not be repeated here. The Reynolds number is much higher and students need specify turbulence model, and thus more variables need to be specified in boundary conditions, as will be discussed in details later.
Navigation Tips

· To zoom in and out use the magnifying glass with a plus sign in it and drag, from top left to bottom right over the are you wish to zoom.

· To look at a view plane, simply click on the arrow in the coordinate system identifier in the bottom right of the screen. i.e if you wish to look at the XYplane, click on the Z Arrow.

3. Open ANSYS Workbench
3.1. Start > All Programs > ANSYS 14.5 > Workbench 14.5
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3.2. From the ANSYS Workbench home screen (Project Schematic), drag and drop the Fluid Flow (Fluent) component from the Toolbox on the left side of the screen into the Project Schematic. Name each component as per below.
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3.3. Create connection as per below by dragging and dropping each component to the corresponding component.
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3.4. Create a Folder on the H: Drive called CFD Lab 1.
3.5. Save the project file by clicking File > Save As…
3.6. Save the project onto the H: Drive in the folder you just created and name it CFD Lab 1 Turbulent Flow.
4. Geometry
4.1. Right click on Geometry and from the drop down menu select New Geometry…
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4.2. Select Meter for unit and click OK. 
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4.3. Select the XYPlane under the Tree Outline and click New Sketch button.
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4.4. Right click XYPlane and select Look at. 
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4.3. Select the X YPlane under the Tree outline and click New Sketch button.
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4.4, Right click XYPlane and sclect Look at.
4.5. Select Sketching > Rectangle and create a rectangle geometry as per below.
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4.5. Select Sketching > Rectangle. Create a rectangle geometry as per below.
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4.6. Select Dimensions > General. Click on top edge then click anywhere. Repeat the same thing for one of the vertical edges. You should have a similar figure as per below.
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4.7. Click on H1under Details View and change it to 6.096m. Click on V2 and change it to 0.02619m.
NOTE: The actual length of the pipe is 30 feet (9.144m), However, in CFD simulation, we need to specify “outlet pressure”, and we don’t have a pressure transducer at the pipe outlet. So we choose the outlet of the pipe we will simulate to be the location of the last pressure transducer, which is 6.096 meters from the pipe inlet.
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4.6. Select Dimensions > General. Click on top edge then click anywhere. Repeat the same thing
for one of the vertical edges. You should have a similar figure as per below.
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4.8. Concept > Surface From Sketches and select the sketch and hit Apply.
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4.8. Concept > Surface From Sketches and sclect the sketeh and hit apply.
4.9. Click Generate. This will create a surface.
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4.9. Click Generate. This will create a surface.
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4.10. File >Save Project. Save project and close window.
5. Mesh
5.1. From the Project Schematic right click on Mesh on the Fluid Flow (Fluent) component and select Edit…
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5.2. Right click on Mesh then select Insert >Mapped Face Meshing.
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5.2. Right click on Mesh then select Insert > Mapped Face Meshing. 
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5.3. Select your geometry by clicking on the yellow box which reads No Selection, then select the surface and click Apply on the left side of the window.
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5.4. Click on the Edge button. This will allow you to select edges of your geometry.
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5.5. Right click on Mesh then select Insert > Sizing. 
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5.6. Hold Ctrl button and select the top and bottom edge then click Apply. Specify Details of “Edge Sizing” - Sizing as per below. 

[image: image20.png]



5.7. Repeat step 5.5.
5.8. Select the left edge then click Apply and change the parameters as per below.
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5.9. Repeat Step 5.5.

5.10. Select the right edge then click Apply and change the parameters as per below.
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5.11. Click on Generate Mesh button and then select Mesh under Outline. The mesh should look like the mesh below.
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5.12. Change the edge names by selecting the edge, then right clicking on the edge and selecting Create Named Selection from the drop down menu. Name left, right, bottom and top edges as inlet, outlet, axis and wall respectively then click OK. Your outline should look same as the figure below. 
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5.13. File > Save Project. Save the project and close the window. Update mesh on Project Schematic by right clicking on Mesh and selecting Update.
6. Physics
6.1. Right click Setup and select Edit…
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6.2. Check Double Precision. 
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6.3. Solution Setup > General > Check. (Note: If you get and error message you  may have made a mistake while creating you mesh)
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6.4. Solution Setup > General > Solver. Choose options shown below.(Note: using axisymmetric sets the derivative du/dy  at the axis to zero. This is considered a boundary condition on the axis.)
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6.5. Solution Setup > Models > Viscous–Laminar > Edit… Select k-epsilon (2 eqn) and click OK.
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6.6. Solution Setup > Materials > air > Create/Edit. Change the Density and Viscosity as per your experimental data. Click Change/Create then close the window. Use the flow property values in your EFD Lab2. If you only know the room temperature when you conducted EFD Lab 2, you can use the following website to easily get the corresponding density and dynamic viscosity for air: http://www.mhtl.uwaterloo.ca/old/onlinetools/airprop/airprop.html
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If the room temperature is 24°, the density and viscosity are the values shown in the above panel. NOTE: viscosity used in ANSYS is the dynamic viscosity (
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), NOT kinematic viscosity (
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6.7. Solution Setup > Cell Zone Conditions > Zone > surface_body. Change type to fluid and click OK. Select Material Name as air and click OK.
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6.8. Solution Setup > Boundary Conditions > inlet > Edit… Change parameters as per your experimental data and click OK. You must calculate the inlet velocity u, which is uniform, based on the flow rate 
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6.9. Solution Setup > Boundary Conditions > outlet > Edit… Change parameters as per experimental data and click OK. You need to transform the four pressure tap pressure values from “feet water” to “Pascal” and input pressure tap #4 value as the “outlet pressure”. For example, if the pressure tap #4 has value of 0.2502 feet water, you need input 747 Pascal.
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6.10. Solution Setup > Boundary Conditions > wall > Edit… Change parameters as per experimental data and click OK. Input the pipe roughness of the pipe you used in EFD Lab2. For example, user inputs 0.000025 m for smooth pipe. 
[image: image43.png]3 A(CFD Lab 1 Turbulent Flow Fluent [axi dp, pbns, ske] [ANSYS Academic Teaching Advanced] i (= B[ X

Bies-H-

Fie Mesh Define Solve

Adapt_Surface

Display Report Paraliel View Help

eisEaasieinm-o-|

Meshing
Mesh Generation
Solution Setup.

Boundary Con B b
= |
=
st by
ey
ar
—
-
Adjacent Cell Zone
e
Momentum | Thermal | Radiation | Species| DPM | Mutishase | ups | wall Fim |
Crm e
o |
it
=
Edit.. No Sip.
| Specified Shear
P | © ety Coicen
Wall Roughness
() Roughness Height () [5.000025 constant. -
Roughness Constant [ 5° constant -
Jul 31,2013
o) |
writing surface_body (type fluid) (mil
writing interior-surface_body (type i
writing inlet (type velocity-inlet) (
writing outlet (type pressure-outlet)
writing axis (type axis) (mixture) ..|
writing wall (type wall) (mixture)
writing zones map name-id ... Done.

Domain Extents:

x-coordinate

y-coordinate:
Volune statistics:

min (m)
min (m)

0.0000000+00, max
0.0000000+00, max

o

]| Cos 'CFD_labl-Exercise_Note(2013)V1.doc [Compatibility Mode] - Microsoft Word

Home | Insert References Review  View  Acrobat

Page Layout

Mailings

4aBbCcl AaBbC AaBb( % L

A7 Emphasis T Heading1 THeading2 _ Change Editing
S AR A (AN SE N " o 92 [o] Change | E4
cippona Font o g o T ]
[l 0 T 0 3 0 5 0 n I 5 I & . =

mininum volume (n3): 1.986895e-85

naxinun
total
Face area
nininun
naxinun

Checking nesh

Done..

volune (nd): 3.133156e-05
volune (n3): 1.5965u2e- 6
statistics:

Face area (n2): 9.31576ke-04
Face area (n2): 1.980851e-02 1

w I v

G e
Turtwlent Specifcation sty and g scie
Reset ox |

At “Axis”, FlowLab uses zero grmdient for axial velocity and Pressure and specify the magnitude for
radial velocity to be zero. Read all the values and click<<OK>>

[Vanabes
Magnitude = [ - -
| BT | K | CO 1 KA | KA

Reset i oK.

At “Outlef”, FlowLab uscs magnitude for pressurc and zero gradicnts for axial and radial velocities.

You need transform the four pressure tap pressure values from “feet water” to “Pascal” and

input pressure tap #4 value as the “outlet pressure”. For example, if the pressure tap #4 has

value of 0.2502 feet water, you need input 747 Pascal.
0

[ sy [Fv sy [Fea) [k mars2y ['e mersa)

—
—

[Variables [atwrsy [Fv sy [Fea [Kmazsz) ['e mzrs3)

IE
[Fim—

[Magniuge || [ =

Zero Gradiel

e
Reset oK.

At “Wall”, no-slip boundary conditions arc fixed for both axial and radial velocity, gradicnt for
pressure is zero. Input the pipe roughness of the pipe you used in EFD Lab2 and choose the
convenient unit you need. For example, user inputs 0.025 mm for smooth pipe.

Variables [utwisy [Fo sy [FFay [kmazsz) ['e mzrs3)
Magnitige || [0 B B [o [o
Zero Gradier || [N D [v N D

mm

Wall Roughness  [0.025
Boeat s

« { o

°

Fage: 200126 | Words: 2486 | B |





6.11. Solution Setup > Boundary Conditions > Operating Condition. Change parameters as per below and click OK. 
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6.12. Solution Setup > Reference Values. Change parameters as per experimental data. Parameters in blue are constant and should be entered as seen below. Parameters in red are from experimental data.
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7. Solution

7.1. Solution > Solution Methods. Change parameters as per below.
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7.2. Solution > Monitors > Residuals –Print, Plot > Edit… Change convergence criterion to 1e-06 for all five equations as per below and click OK. 
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7.3. Solution > Solution Initialization. Change parameters as per experimental data and click Initialize. Parameters in blue are constant and should be entered as seen below. Parameters in red are from experimental data.
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7.4. Solution > Run calculation. Change Number of Iterations to 1000 and click Calculate.
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7.5. Once the solution converges, click OK. (The residuals should be comparable to the ones below.)
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7.6. File > Save Project. Save the project.

8. Results
8.1. Displaying Mesh

Display > Mesh. Select all Surfaces you wish to be visible and select Display then click Close. 
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Zoom in to the inlet by using the magnifying glass with a plus sign in the middle of it. The mesh should look like the one below.
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8.2. Saving Pictures

To save a picture of the screen, select File > Save Picture… Make sure all the parameters are set similar to the ones below and click Save…
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Name the File as CFD Lab 1 Mesh, navigate to the CFD Lab 1 file you created and save it in that file. Close the Save Picture window.
8.3. Displaying and Saving Residuals

To display the residuals click Solution > Monitors > Residuals – Print, Plot > Edit… > Plot then click Cancel.
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You can save this picture the same way you saved the mesh. Name it CFD Lab 1 Residuals and save it to the folder you created on the H: Drive.

8.4. Plotting and Saving Results

To plot results, click Results > Plots > XY Plot > Set Up…
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To plot the Centerline Pressure Distribution, copy the parameters as per below. Next click Load File…, select the file named pressure-EFD-turbulent-pipe.xy and click OK. Then click Plot. This .xy file can be downloaded from the class website. The plot should look similar to the one below.     http://www.engineering.uiowa.edu/~fluids/ 
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You can save this picture the same way you saved the mesh. Name it CFD Lab 1 Center Line Pressure with EFD and save it to the folder you created on the H: Drive.

To plot Centerline Velocity Distribution, copy the parameters as per below, select Pressure Profile from the File Data menu, make sure that it is NOT highlighted, and click Plot.
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Save the picture as you did for the mesh and call it CFD Lab 1 Centerline Velocity Distribution and save it in the folder you created.

To plot the Wall Shear Stress Distribution, copy the parameters as per below and click Plot.
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Save the picture as you did for the mesh and call it CFD Lab 1 Wall Shear Stress Distribution and save it in the folder you created.

To plot Profiles of Axial Velocity at All Axial Locations with EFD Data, click Surface > Line/Rake…
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Change x and y values as per below, name the surface, and click Create. Repeat this for all the lines shown in the table below.
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	Surface Name
	X0
	Y0
	X1
	Y1

	x=10d
	0.5238
	0
	0.5238
	0.02619

	x=20d
	1.0476
	0
	1.0476
	0.02619

	x=40d
	2.0952
	0
	2.0952
	0.02619

	x=60d
	3.1428
	0
	3.1428
	0.02619

	x=100d
	5.238
	0
	5.238
	0.02619


When all lines are created, click Close. Next you should open the file axialvelocityEFD-turbulent-pipe.xy with a text editor and replace the velocity values with the values you recorded experimentally. Save the file. 

Click Load File… and select axialvelocityEFD-turbulent-pipe.xy, which is the file you just modified, and click OK. Change Parameters as per below. Make sure to select inlet as well.
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Click Curves… > Change the Pattern to the pattern seen below and click Apply. Do this for curves 0 through 7 then click Close.
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Click Plot.
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Save the picture as you did for the mesh and call it CFD Lab 1 Axial Velocity at All Axial Locations with EFD Data and save it in the folder you created.

8.5. Plotting and Saving Graphics

Click Results > Graphics and Animations > Vectors > Set Up…

To plot the velocity vectors at the region flow begin to become fully developed, copy the parameters as per below and click Display.
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Save the picture as you did for the mesh and call it CFD Lab 1 Velocity Vectors at The Region Flow Begin to Become Fully Developed and save it in the folder you created.

Click Results > Graphics and Animations > Contours > Set Up…

To plot the Contours of Axial Velocity, copy the parameters as per below and click Display.
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Save the picture as you did for the mesh and call it CFD Lab 1 Contours of Axial Velocity and save it in the folder you created.

8.6. Exporting Results

To export Results, click Results > Plots > XY Plot > Set Up… 
To export the Developed Axial Velocity Profile at x=100d, copy the parameters as per below and click Write…
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Name the file CFD Lab 1 Developed Axial Velocity Profile and leave the Files of Type: as XY Files.

To export the centerline pressure distribution, copy the parameters as per below and click Write…
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Name the file CFD Lab 1 Centerline Pressure Distribution and leave the Files of Type: as XY Files.

File > Save Project. Save the project and close the window.
8.7. Normalizing Velocity Profile

· Open the Excel sheet you created in CFD Pre-Lab 1 from your folder on the H: drive.

· Open the CFD Lab 1 Developed Axial Velocity Profile.xy file you just created in a text editor program.

· Copy the velocity and position data from the text program and paste it into the Excel sheet, make sure to label it accordingly.

· Normalize the velocity profile by dividing every velocity by the Centerline Velocity (Max Velocity).

· Edit the plot to include only AFD Velocity Profile (Laminar) and CFD Velocity Profile (Turbulent).

· File > Save As, name the file CFD Lab 1 Developed Axial Velocity Profile.xlsx and save it into your CFD Lab 1 folder on the H: drive.

9. Exercises
You need to complete the following assignments and present results in your lab reports following the lab report instructions
Simulation and Validation of Turbulent Pipe Flow
1. Validation of CFD using EFD data
Follow instructions and setup the simulation case using the same flow conditions as in your EFD Lab2, use the values in instruction part for other parameters, iterate the simulation until it converges. Find the relative error between EFD friction factor and friction factor computed by CFD, which is computed by:
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Use ANSYS Fluent to show the comparison between CFD and EFD on: fully developed axial velocity profile and pressure distribution along the pipe. 
· Figures need to be saved: 1. residual history, 2. centerline pressure with EFD, 3. profiles of axial velocity at all axial locations (x/d=10, 20, 40, 60, 100) with EFD data, 4. centerline velocity distribution, 5. wall shear stress distribution, 6. contour of axial velocity, and 7. velocity vectors (pick up the region where flow begins to become fully developed).
· Data need to be saved: 1. wall friction factor in the developed region, 2. developing Length
2. Normalized developed axial velocity profile

2.1. Export the axial velocity profile data at x=100d only.
2.2. Use EXCEL to open the file you exported and normalize the profile using the 

centerline velocity magnitude, which is the maximum value of the profile. Plot the normalized turbulent and laminar flow 
3. Questions need to be answered in CFD Lab 1 report
3.1. Where is the mesh clustered? Near the wall or near the axis? Why?

      3.2 In the developed region, is the pressure constant? Where are the minimum and 
            maximum pressure locations? What does the axial velocity profile look like? Where 
            does it reach maximum and minimum?
      3.3 Where is the developing region? How can you determine the length of the developing 
            region? (hint: centerline velocity). What is the difference for axial velocity profile 
            between “developing” region and “developed” region?

3.4. Compare the normalized axial velocity profiles for laminar and turbulent pipe flows 
       at x=100d, discuss the difference of axial velocity gradient (du/dy) on the wall, which 

       is larger?
            3.5. What are the correct boundary conditions (velocities u, v and pressure) on the pipe 

                   wall and on the pipe centerline?
            3.6. Summarize your findings and use the knowledge you learned from classroom 

                   lectures, textbooks and ANSYS figures to answer questions.
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