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1. Purpose  
 
The Purpose of CFD Lab 1 is to simulate steady laminar and turbulent pipe flow following the 

“CFD Process” by an interactive step-by-step approach. Students will have “hands-on” 

experiences using ANSYS to compute axial velocity profile, centerline velocity, centerline 

pressure, and friction factor. Students will conduct verification studies for friction factor and 

axial velocity profile of laminar pipe flows, including iterative error and grid uncertainties and 

effect of refinement ratio on verification. Students will validate turbulent pipe flow simulation 

using EFD data, analyze the differences between laminar and turbulent flows, and present results 

in CFD Lab report. 
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2. Simulation Design 
 

In CFD Lab 1, simulation will be conducted for laminar and turbulent pipe flows. Reynolds 

number is 655 for laminar flow and 111,569 for turbulent pipe flow, based on pipe diameter. The 

schematic of the problem and the parameters for the simulation are shown below. 

 

 
Table 1 - Main particulars 

Parameter Unit Value 

Radius of Pipe m 0.02619 

Diameter of Pipe m 0.05238 

Length of the Pipe m 7.62 

 

        

 
 

Since the flow is axisymmetric we only need to solve the flow in a single plane from the 

centerline to the pipe wall. Boundary conditions need to be specified include inlet, outlet, wall, 

and axis, as will be described details later. Uniform flow was specified at inlet, the flow will 

reach the fully developed regions after a certain distance downstream. No-slip boundary 

condition will be used on the wall and constant pressure for outlet. Symmetric boundary 

condition will be applied on the pipe axis. Uniform grids will be used for the laminar flow 

whereas non-uniform grid will be used for the turbulent flow. 
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Table 2 - Grids 

Grid   Grid Type 
# of Divisions 

X R 

8 

Uniform 

453 45 

7 320 32 

6 227 23 

4 113 11 

3 80 8 

2 57 6 

0 28 3 

T Non-uniform  564 15 

 

Experimental, analytical and simulations will be compared. Additionally, detailed verification 

and validation study will be conducted. All the studies are detailed in the Table 3. In this manual, 

detailed instructions are given for the turbulent flow simulation and laminar flow simulations 

using non-uniform grid and uniform grid 8 respectively. Figures and data that needs to be saved 

are shown in Table 4. 

 

Table 3 - Simulation matrix 

Study Grid Model 

V&V of friction factor and axial velocity profile 2,3,4 

Laminar 

V&V of friction factor 6,7,8 

V&V of friction factor 0,2,4 

V&V of friction factor 4,6,8 

Axial velocity, centerline velocity 8 

Axial velocity, centerline pressure, centerline velocity T Turbulent 

 

 

 

All analytical data (AFD) for Laminar Pipe Flow and EFD data for turbulent pipe flow can be 

downloaded from the class website (http://css.engineering.uiowa.edu/~me_160).  
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Table 4 - Figures and data sets needed to be saved 

Grid Flow 

Convergence 

Limit Figure Data 

T Turbulent 1.00E-06 *   

8 Laminar 1.00E-06 Residuals ** 

8 Laminar 1.00E-05 Residuals Wall Shear Stress 

7 Laminar 1.00E-06   Wall Shear Stress 

6 Laminar 1.00E-06   Wall Shear Stress 

4 Laminar 1.00E-06   Wall Shear Stress 

4 Laminar 1.00E-05   Wall Shear Stress 

3 Laminar 1.00E-06   Wall Shear Stress 

2 Laminar 1.00E-06   Wall Shear Stress 

0 Laminar 1.00E-06   Wall Shear Stress 

* Axial velocity profile with EFD data, normalized axial velocity profile at x=100D, 

centerline pressure distribution with EFD data, “centerline velocity distribution”, contour 

of axial velocity, velocity vectors  showing the developing region and developed regions. 

**Wall Shear Stress, velocity profile (10pts), centerline velocity distribution 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



3. Open ANSYS Workbench Template 
3.1. Start > All Programs > ANSYS 14.5 > Workbench 14.5 

 

3.2. Toolbox > Component Systems. Drag and drop Geometry, Mesh and Fluent 

components to Project Schematic as per below.  

 

3.3. Right click on the upper corner of the components on the drop down arrow then select 

rename. Change the names as per below. 



 

 

3.4. Create connections between component as per below. You can select components part 

and drop it onto the target component part to create connections.  



 

3.5. File > Save As. Save the workbench file to H drive. The H drive is shared between the 

computers in engineering labs. 

 

 

4. Geometry Creation 
4.1. Right click Geometry and select New Geometry. (Since all the geometries are linked 

together, only one geometry creation is required) 



 

4.2. Select Meter for unit and click OK. 

 

4.3. Select the XYPlane under the Tree Outline and click New Sketch button. 

 

 

 

 

 



4.4. Right click XYPlane and select Look at. 

 

4.5. Select Sketching > Rectangle. Create a rectangle geometry as per below. 

 
 

4.6. Select Dimensions > General. Click on top edge then click anywhere. Repeat the same 

thing for one of the vertical edges. You should have a similar figure as per below. 



 
4.7. Click on H1 under Details View and change it to 7.62 m. Click on V2 and change it to 

0.02619 m. 

 

 

4.8. Concept > Surface From Sketches and select the sketch and hit Apply. 

 

4.9. Click Generate. This will create a surface. 

 

 



 

4.10. File > Save Project. Save project and close window. 

 

4.11. If you see the lightning sign next to Geometry in the workbench then right click 

on Geometry and click Update as shown below. If you don’t see the check mark after 

you update then you may have made a mistake when you created the geometry.  

 



 

 

5. Mesh Generation 
5.1. Right click Mesh and select Edit.  

 

 

5.2. Right click on Mesh then select Insert > Mapped Face Meshing.       

 



 

 

5.3. Select your geometry and click Apply. 

 

 

 

5.4. Click on the Edge Button. This will allow you to select edges of your geometry. 



 

5.5. Right click on Mesh then select Insert > Sizing. 

 

5.6. Hold Ctrl and select the top and bottom edge then click Apply. Specify details of sizing 

as per below. 

 

Laminar 

 

 

 

 



Turbulent 

 

5.7. Repeat step 5. Select the left and right edge and click Apply for uniform grid flow and 

change sizing parameters as per below. Change the sizing parameters separately for non-

uniform grid as per below. Make sure to select edges individually when changing sizing 

parameters for non-uniform grid. 

Uniform Grid 8 

 

Non-uniform Grid Left Edge 

  



Non-uniform Grid Right Edge 

 

5.8. Click on Generate Mesh button and select Mesh under Outline. 

 

 

 

 

Uniform Grid 8 Non-uniform Grid 



5.9. Change the edge names by right clicking and selecting Create Named Selection. Name 

left, right, bottom and top edges as inlet, outlet, axis and wall respectively. Your outline 

should look same as the figure below. 

 

 

 

 

 



 

 

5.10. File > Save Project. Save the project and close the window. Update Mesh on 

Workbench if necessary. 

 

 

 

 

Uniform Grid 8 Non-uniform Grid 



6. Solve 
6.1. Right click Setup and select Edit. 

 

 

6.2. Under options check Double Precision and click OK.  

 

 

 

 



6.3. Solution Setup > General > Check. (Note: If you get and error message you may have 

made a mistake while creating you mesh) 

 

 

 

6.4. Solution Setup > General > Solver. Choose options shown below. 

 



 

6.5. Solution Setup > Models > Edit. Select parameters as per below. 

Laminar flow 

 

 

 

 



Turbulent flow 

 

 

6.6. Solution Setup > Materials > air > Create/Edit… Change the Density and Viscosity 

as per below and click Change/Create. Close the dialog box when finished. 

 

6.7. Cell Zone Conditions > Zone > surface_body. Change type to fluid and click OK. 

Select Material Name as air and click OK. 

 

 

 

 

 

 



 

 

6.8. Solution Setup > Boundary Conditions > inlet > Edit… Change parameters as per 

below and click OK. (Note: Change inlet velocity to 0.2 m/s for laminar flow) 

 

 

 

 



Laminar flow 

 

Turbulent flow 

 

6.9. Solution Setup > Boundary Conditions > outlet > Edit. Change parameters as per 

below and click OK. (Note: Outlet pressure is 0 Pa for laminar flow) 

 

 

 

 

 

 

 

 

 

 
 

 

 

 

 



Laminar flow 

 

Turbulent flow 

 

 

6.10. Solution Setup > Boundary Conditions > wall > Edit… Change parameters as 

per below and click OK. 

 

 

 

 

 

 

 

 

 

 

 

 



Turbulent flow 

 

 

6.11. Solution Setup > Boundary Conditions > Operating Condition. Change 

parameters as per below and click OK. 

 

 

 

 

 

 

 

 



6.12. Solution Setup > Reference Values. Change parameters as per below.  

Laminar flow 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Turbulent flow 

 

 

6.13. Solution > Solution Methods. Change parameters as per below. 

 

 

 

 

 

 

 

 

 

 



Turbulent flow 

  

Laminar flow 

 

 

 



6.14. Solution > Monitors > Residuals > Edit. Change convergence criterion to 1e-6 

for all five equations as per below and click OK. (Note: for iterative error study you will 

need to use 1e-5) 

Laminar flow 

 

Tubulent flow 

 

 

6.15. Solution > Solution Initialization. Change parameters as per below and click 

Initialize. (Note: use 0 Pa and 0.2 m/s for laminar flow for pressure and velocity 

respectively) 

 

 

 

 

 

 

 



Turbulent flow                                                                          

 

 

 



Laminar flow                                           

 

 

6.16. Solution > Run calculation. Change number of iterations to 1000 and click 

Calculate. 

 

 

 

 

 

 

 



7. Post Processing 

Displaying Mesh 

 Display > Mesh 

 

Select all the surface you want to display, lines and points you create can be displayed here as 

well. 

Plotting and Printing Residuals 

Display > Residuals. Click on Plot button then click on OK. 

 

 

 



 

 

File > Save Picture. Using option as per below save the residuals. 

 

 



 

 

 

Creating Points and Lines 

Surface > Point. Change x and y values as per below click Create. Repeat this for other lines 

shown in the table below. 

 

 

 

 



 

Point 

Name 
x0 y0 

point-1 7 0 

point-2 7 0.005 

point-3 7 0.010 

point-4 7 0.015 

point-5 7 0.020 

point-6 7 0.021 

point-7 7 0.022 

point-8 7 0.023 

point-9 7 0.024 

point-10 7 0.025 

 

Surface > Line/Rake. Change x and y values as per below click Create. Repeat this for other 

lines shown in the table below. 

 

 



 

Surface 

Name 
X0 Y0 X1 Y1 

x=10d 0.5238 0 0.5238 0.02619 

x=20d 1.0476 0 1.0476 0.02619 

x=40d 2.0952 0 2.0952 0.02619 

x=60d 3.1428 0 3.1428 0.02619 

x=100d 5.238 0 5.238 0.02619 

 

Plotting Results 

Results > Plots > XY Plot > Setup. Select inlet, outlet, and the lines you created and change 

setting as per below then click Plot.  

 

 

 



 

XY Plot > Setup > Curves. For Curve # 0 select the Pattern as per below and click Apply. 

Repeat this for all the curves 0 through 7. 

 

Download the data for the Simulation from the class website 

(http://www.engineering.uiowa.edu/~me_160/). 

XY Plot > Setup > Load File. Select axialvelocityEFD-turbulent-pipe.xy and click OK.  

 

  

 

 

 

http://www.engineering.uiowa.edu/~me_160/


 

Results > Plots > XY Plot > Setup. Change Y function to Pressure… and select axis then click 

Plot. 

 

Load experimental data for the centerline pressure.  

 

  

 



 

Select axis and change Plot Direction as per below. Then plot the figure. 

 

 

 

 



Exporting Data 

Select Plots > XY Plot. Then change parameter as per below and click Write. This will export 

the shear stress along the wall of the pipe. You will need this data to compute the shear stress 

coefficient at the developed region. 

 

 

Plotting Vectors and Contours 

Results > Graphics and Animations > Vectors > Set Up… Change the vector parameters as 

per below and click Display. 

 

 

 

 

 

 

 



 

Results > Graphics and Animations > Contours > Set Up… Change the vector parameters as 

per below and click Display. 

 

 

Close window and save workbench file. 

 

 

 
 

 



V&V Instructions 

V&V Instructions for Velocity Profile 

Right click Solution > Select Edit… 

 

Create reference points 

Results > Plots > XY Plot > Set Up… 



 

Change parameters as per below and click Write… Make sure to select points 1 through 10. 

 

Name file according to which grid solution you are using. 

 

 

 
 

 

 



 

Open file using Wordpad, copy points to input into V&V Excel file. 

 

Paste value into V&V Excel file according to its y position and its grid number. Use the Keep Text Only 

paste function by right clicking in the cell and selecting it from the paste options. 



 

Repeat this process for the remaining y location points and then the two remaining grid solutions. All 

yellow cells should be filled. 

V&V Instructions for Friction 

Right click Solution > Select Edit… 

 

 



 

Results > Plots > XY Plot > Set Up… 

 

 

Change parameters as per below and click Write… 

 

 

 

 

 



Name the file according to grid number and save to project folder. 

 

Open file with Notepad and copy wall shear stress at the x location of 7.62m. 

 

Paste the value into corresponding cell in the V&V template. 

 

 



 

Make sure when pasting you select Keep Text Only and you select the proper cell corresponding to the 

grid number. 

 

Repeat this process for the remaining six grids. Each yellow cell should be filled. 

  

 



8. Exercises 
 

You need complete the following assignments and present results in your lab reports following 

the lab report instructions. 
 

                                      * 1-4 and 6 are for laminar flows, 5 is for turbulent flows 

               

8.1. Iterative error studies: Use grid #4 and #8 with laminar flow conditions. Use two 

different convergent limits 10
-5

 and 10
-6

 and fill in the following table for the values on 

friction factors. Find the relative error between AFD friction factor (0.097747231) and 

friction factor computed by CFD, which is computed by: 

 

 

To get the value of CFDFactor , you need export wall shear stress data. Then use the wall 

shear stress at the developed region to calculate the friction factor. The equation for the friction 

factor is C=8*τ/(r*U^2). Where C is the friction factor, t is wall shear stress, r is density and U is 

the inlet velocity. Discuss the effect of convergent limit on results for these two meshes  

 

Mesh 

No. 

f (10
-5

) F(10
-6

) 

4                    (       %)                  (     %) 

8                    (       %)                  (     %) 

NOTE: (1). X and R should be NX+1 and NR+1. So, when you can create mesh manually, 

you need use NX, NR (112×10) for mesh 4 and (452×44) for mesh 8.             

 Figure need to be saved: residuals history for mesh 8 for two convergent limits. 

 Data need to be saved: the above table with values. 

 ANSYS case need to be saved: mesh 8 with convergent limit 10
-6

 

 

8.2. Verification study for friction factor of laminar pipe flow: Run the simulations 

with the meshes shown in the table. Using mesh 4 as the “fine” mesh, and run 

verification with grid refinement ratio 1.414 and convergence limit 10
-6

. Compute the 

parameters in the table (Refer to class website for V&V instructions). Using Mesh 8 as 

the “fine” mesh and repeat the above procedure using the same grid refinement ratio 

1.414. 

    Meshes Pg Cg Ug(%) Ugc (%) 

2,3,4     

6,7,8     

        

Which set of meshes is closer to the asymptotic range (i.e. Cg close to 1.0)? Which set has a 

lower grid uncertainty (Ug)? Which set is closer to the theoretical value of order of accuracy 

(2nd order). For the fine mesh 8, also compare its relative error of the friction factor (the one 

100%CFD AFD

AFD

Factor Factor

Factor






using convergent limit 10
-6

 in the table in exercise 1) with the grid uncertainty for 6,7,8, which is 

higher and what does that mean? 

 

 Figure need to be saved: Figures and tables from V&V spread sheet. 

 Data need to be saved: the above table with values 

 

8.3. Effect of grid refinement ratio on verification results (friction factor): Still 

use mesh 4 and 8 as the “fine mesh”, but run verification with grid refinement ratio 2 for 

laminar pipe flow and convergence limit 10
-6

.  

Meshes Pg Cg Ug(%) Ugc (%) 

0,2,4     

4,6,8     

 

Compared to results in 2, which set of meshes is sensitive to grid refinement ratio? Why? 

 Figures need to be saved: Figures and tables from V&V spread sheet. 

 Data need to be saved: the above table with values 

 

8.4. Verification study of axial velocity profile: Use mesh 4 as the “fine mesh”, use 

grid refinement ratio 1.414 and convergence limit 10
-6

. Follow the V&V for velocity 

how to in the post processing section. Save the figures and discuss if the simulation has 

been verified.  

 Figures need to be saved: Figures showing Ug, Ugc with |E|. Discuss which mesh 

solution is closest to the AFD data, why? 

 Data need to be saved: None. 

 

8.5. Simulation of turbulent pipe flow 
Run simulation with convergence limit 10

-6 
and compare with EFD data on axial velocity 

profile and pressure distribution along the pipe. Export the axial velocity profile data at x=100D, 

use EXCEL to open the file you exported and normalize the profile using the centerline velocity 

magnitude at x=100D. Plot the normalized velocity profile in EXCEL and paste the figure into 

WORD. 

 Figures need to be saved: Axial velocity profile with EFD data, normalized axial velocity 

profile at x=100D, centerline pressure distribution with EFD data, “centerline velocity 

distribution”, contour of axial velocity, velocity vectors  showing the developing region and 

developed regions. 

 Data need to be saved: Developing length and compared it with that using formula 6.6 in 

textbook. 

 

8.6. Comparison between laminar and turbulent pipe flow 
Compare the results of laminar pipe flow using mesh 8 in exercise 1 (convergent limit 10

-6
) 

with results of turbulent pipe flow in exercise 5.  Analyze the difference in normalized axial 

velocity profile and developing length for laminar and turbulent pipe flows. 

      NOTE: (1). Since you have finished laminar simulation using mesh 8 in exercise 1, you 

can just open the case file you saved and output the figures and data you need. 



 Figures need to be saved: Axial velocity profile with AFD data, normalized axial velocity 

profile at x=100D, “centerline velocity distribution” for laminar flows. 

 Data need to be saved: Developing length for laminar pipe flow and compared it with that 

using formula 6.5 in textbook.  

 

8.7. Questions need to be answered in CFD Lab report 
8.7.1. Answer all the questions in exercises 1 to 6 
8.7.2. Analyze the difference between CFD/AFD and CFD/EFD and possible error   sources. 
8.7.3. Analyze the difference between ANSYS predictions and your own calculations (using 

formula in CFD lecture) for order of accuracy and grid uncertainties. 
 


