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1. Purpose

The Purpose of CFD PreLab 1 is to teach students how to use the CFD educational interface (ANSY'S),
be familiar with the options in each step of CFD Process, and relate simulation results to AFD concepts.
Students will simulate laminar pipe flow following the “CFD process” by an interactive step-by-step
approach. Students will have “hands-on” experiences using ANSY'S to compute axial velocity profile,
centerline velocity, centerline pressure, and wall shear stress. Students will compare simulation results
with AFD data, analyze the differences and possible numerical errors, and present results in CFD Lab

1 report.
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2. Simulation Design

In EFD Lab 2, you conducted experimental study for turbulent pipe flow. The data you have
measured will be used for CFD Lab 1. In CFD PreLab 1, simulation will be conducted only for
laminar circular pipe flows, i.e. the Reynolds number is less than 2300. Reynolds number based on
pipe diameter and mean inlet velocity is 654.75 in the current simulation. CFD predictions of friction
factor and fully developed axial velocity profile will be compared with AFD data.

Table 1 — Geometry dimensions

Parameter Unit | Value
Radius of Pipe m 0.02619
Diameter of Pipe m 0.05238
Length of the Pipe m 7.62

Non-uniform mesh Uniform mesh
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Figure 1 - Geometry

Since the flow is axisymmetric we only need to solve the flow in a single plane from the centerline to
the pipe wall. Boundary conditions need to be specified include inlet, outlet, wall, and axis, as will
be described in details later. Uniform flow is specified at inlet, the flow will reach the fully developed
regions after a certain distance downstream. No-slip boundary condition will be used on the wall and
constant pressure for the outlet. Symmetric boundary condition will be applied on the pipe axis. Since
the flow is laminar, turbulence models are not necessary.

Navigation Tips
e Tozoom in and out use the magnifying glass with a plus sign in it and drag, from top left to
bottom right over the are you wish to zoom.
e To look at a view plane, simply click on the arrow in the coordinate system identifier in the
bottom right of the screen. i.e if you wish to look at the XYplane, click on the Z Arrow.



3. Open ANSYS Workbench

3.1. Start > All Programs > ANSYS 14.5 > Workbench 14.5

E-J Windows Update
B winRar
~# XPS Viewer

.. Abaqus612-1

| Accessories

.. ActivePerl 5.16.3 Build 1603 (64-bit) E

| ANSYS 145
=k ANSYS leepak 14.5
I\ Mechanical APDL14.5

A Mechanical APDL Product Launcher

I\ Uninstall 14.5

I\ Workbench 145

| ANSYS Client Licensing
. Agwa

. EKM

. Fluid Dynamics

. Help

. Meshing

. Remote Sclve Manager
L Utilities

4 Back

| ‘Ss:r:-“ programs and files

3.2. From the ANSY'S Workbench home screen (Project Schematic), drag and drop the Geometry

component for the Component Systems on the left side of the screen into the Project
Schematic. Rename the geometry by right clicking on the down arrow of the Geometry

component and selecting Rename.
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3.3. Drag and drop two Mesh components and two Fluent components into the schematic as shown
below. Rename the components as you did the geometry previously as per the as shown below.
Make the connections as per below by dragging component to component.
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3.4. Create a Folder on the H: Drive called CFD Pre-Lab and Lab 1.
3.5. Save the project file by clicking File > Save As...

3.6. Save the project onto the H: Drive in the folder you just created and name it CFD Pre-Lab and
Lab 1 Pipe Flow. (This will be used for both Pre-Lab 1 and Lab 1.)

4. Geometry Creation
4.1. Right click on Geometry and from the drop down menu select New Geometry...
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4.3. Select the XYPlane under the Tree Outline and click New Sketch button.
B A: Fluid Flow (FLUENT) Mod

J File Create Concept Tools View Help
| A HE @ | DU Greso [[seect[ B  BR R (0[S ¢ QAQAQEAQQE [+ [0 [0
J W~ A~ Jiv A~ A~ A~ —
J N¥Plane - # ‘ MNone MJ :} Generate W Share Topaology | R Bxdrude *Revolve e Sweep 4§ SkinfLoft W Thin/Surface B
Tree Qutline ics
E|---‘, A: Fluid Flow (FLUENT)
7 Z¥Plane
3 YZPlane
i M@ 0 Parts, 0 Bodies

4.4. Right click XYPlane and select Look at.
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4.5. Select Sketching > Rectangle. Create a rectangle geometry as per below, make sure to start
from the origin, the mouse arrow should change to a “P”” when on the origin.
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4.6. Select Dimensions > General. Click on top edge then click above the geometry to place the
dimension. Repeat the same thing for one of the vertical edges. You should have a similar
figure as per below.

4.7. Click on Hlunder Details View, in the bottom left of the screen, and change H1 to 7.62m.
Click on V2 and change it to 0.02619m.
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4.8. Concept > Surface From Sketches, select the sketch by clicking on Sketch 1 in the Tree
Outline and hit Apply in the Detatils View.
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4.9. Click Generate. This will create a surface.
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4.10. File >Save Project. Save project and close the Design Modeler window.

5. Mesh Generation
5.1. From the Project Schematic right click on Mesh on the Fluid Flow (Fluent) component and
select Edit...

J\ CFD Pre-Lab 1 - Workbenc|

File View Tools Units Extensions Help
|_1 New [ Open... A save ﬂSave As... | ﬁ]lmport... | <pReconnect @ Refresh Project # Update Project | @Project OCompact Mode

BPRO rcicct schemati <2 x

Analysis Systems —
E Component Systems
@ Autodyn
@) CRX
@ Engineering Data = 2 @ Geometry ' @2 =
g Externa:Connectlon pipe i " P
gml External Data 2. .
= 53 Duplicate
(@ Finite ElementModeler r
Fluent Transfer Data To New 3
Fluent (with TGrid meshing) #  Update
e Geametry Clear Generated Data
4 ICEM CFD i
n Mechanical APDL & Refresh
@ Mechanical Model Reset
@ Mesh EE Rename
[P Microsoft OfficeExcel Properties
=% Polyflow
=i Polyflow- Blow Molding = Quick Help
| T View Al / Customize. .. Add Note
@ Right-clickto update component. (1 Show Progr Hlv__lﬂmw‘

5.2. Right click on Mesh then select Insert > Mapped Face Meshing.



(%) A: CFD Prelab 1 Laminar Flow - Meshing [ANSYS Academic Teaching Advanced] . B .'- .-. - e _— =l
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5.3. Select your geometry by clicking the yellow box which says No Selection, the click on the

geometry surface, and click Apply.
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5.4. Click on the edge button. This will allow you to select edges of your geometry.



@ A CFD Prelab 1 Laminar Flow - Meshing [ANSYS Academic Teaching Advanced] .
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5.5. Right click on Mesh then select Insert > Sizing.
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5.6. Hold Ctrl button and select the top and bottom edge of the rectangle then click Apply. Specify
details of sizing as per below in the Details of “Edge Sizing” — Sizing window.

Details of "Edge Sizing" - Sizing a
[=| Scope

Scoping Method Geometry Selection

Geometry 2 Edges
[=1| Definition

Suppressed Ma

Type MNumber of Divisions

Mumber of Divisions | 453
Behavior Hard
Bias Type Mo Bias

5.7. Repeat step 5.5. Select the left and right edge of the rectangle and click Apply then change
sizing parameters as per below.



Details of "Edge Sizing 2" - Sizing 1

[=]| Scope
Scoping Method Geometry Selection
Geometry 2 Edges
[=]| Definition
Suppressed Mo
Type Mumber of Divisions
Mumber of Divisions |45
Hard -
Bias Type Mo Bias

5.8. Click on Generate Mesh button. Click Mesh under Outline. The mesh should look like the

mesh pictured below.
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5.9. Change the edge names by selecting the edge, then right clicking on the edge and selecting

Create Named Selection. Name left, right, bottom and top edges as inlet, outlet, axis and wall

respectively. Your outline should look same as the figure below.
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5.10.
Schematic by right clicking on Mesh and selecting Update.
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File > Save Project. Save the project and close the window. Update mesh on Project
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6. Setup (Physics)

6.1. Right click Setup

N
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6.2. Check Double Precision and click OK.
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6.3. Solution Setup > General > Check. (Note: If you get an error message you may have made a
mistake while creating you mesh. Review steps in mesh generation and make changes.)

Meshing General
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Plots
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6.4. Solution Setup > General > Solver. Choose options shown below.
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6.5. Solution Setup > Models > Edit... Make sure Laminar is selected and click OK.
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6.6. Solution Setup > Materials > air > Create/Edit. Change the Density and Viscosity as per
below and click Change/Create. Close the dialog box when finished.

Meshing

Mesh Generation
Solution Setup
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6.7. Solution Setup > Cell Zone Conditions > Zone > surface_body. Change type to fluid and
click OK. Select Material Name as air and click OK. This should be defaulted to fluid.

Meshing
Mesh Generation
Solution Setup
General

Models
Materials

“EII Zone Conditions

Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values

Solution
Solution Methods
Solution Controls
Monitors
Solution Initialization
Calculation Activities
Run Calculation

Results

Graphics and Animations

Plots
Reports

Cell Zone Conditions

surface_body

Phase
mixture

[ Parameters... ] [Dperating Conditions... ]

Porous Formulation
(@) Superfical Velodty
Physical Velocity

14



= =

Zone Mame

| surface_body

Material Namg i - ]I[ Edit... |

|:| Frame Motion |:| Source Terms
[ Mesh Motion  [] Fixed Values
[] Porous Zone

Reference Frame | Mesh Motion | Porous Zone | Embedded LES | Reaction | Source Terms | Fixed 'I.n'aluesl Mulﬁphasel

This page is not applicable under current settings.

@ Cancel Help

6.8. Solution Setup > Boundary Conditions > inlet > Edit... Change parameters as per below
and click OK. Table below shows the summary of

Inlet Boundary Condition
Variable u(m/s) | v(m/s) | P(Pa)
Magnitude 0.2 0 -
Zero Gradient N N Y
- Boundary Conditions Cer— W)
Mesh Generation Zone | Zone Name
Solution Setup i | inlet
Models i = ) )
Materisls outlet Momentum |Therma|| Radlahonl Speclesl DPM | Mulhphasel ups |
]
Pases ‘‘‘‘‘‘‘ e Velodty Spedfication Methor Magnitude, Normal to Boundary vI
Reference Frame | phsolute v]

Dynamic Mesh Velocity Magnitude (m/s)[ o 5 constant v]

Reference Values
Supersonic/Initial Gauge Pressure (pasa[1| 0 constant v]

Solution
Solution Methods
Solution Controls
Woritars | Coc )] (concel) [k )
Solution Initizlization

Calculation Activities
Run Calculation Fhase

Type jin]
Results mixture velodty-nlet - | 7

Graphics and Animations 1e-12
Flots [ Edt.. ]l Copy... |[Profies... | i 100 o

Reparts | Parameters... | | Operating Conditions... ]

Display Mesh... | | Periodic Conditions...

1e-10
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6.9. Solution Setup > Boundary Conditions > outlet > Edit... Change parameters as per below
and click OK.

Outlet Boundary Condition
Variable u(m/s) | v(m/s) | P (Pa)
Magnitude - - 0
Zero Gradient Y Y N
I x
Meshing Boundary Conditions e Om_je‘—+
Mesh Generation Zone Zone Name
Solution Setup axis | outlet
General ?”lEt_
Models Momentum | Thermal | Radiation | Speces| DPM | Multiphase| ups |
Materials
Phases N Gauge Pressure (pascallfl o I[mnstant v]
@ Backflow Direction Spedfication Method [Normal to Boundary ,]
Dynamic Meh [] average Pressure Specification
Reference Values [ Target Mass Flow Rate
Solution
Solution Methods
Solution Controls

Manitors — -
Solution Initislization
Calculation Activities 1e-08
Run Calculation Fhase Type i)
1e-10

Graphics and Animations

Flots Edit... Copy... Profiles...
Reports Parameters... | | Operating Conditions... 112
Perindic Conditions... 0 100 200 300 400 500 GO0

6.10. Solution Setup > Boundary Conditions > wall > Edit... Change parameters as per
below and click OK.

Wall Boundary Condition
Variable u(m/is) | v(mis) | P (Pa)
Magnitude 0 0 -
Zero Gradient N N Y




6.11.

A

Wall

B

Zone Mame

| wall

Adjacent Cell Zone

| surface_body

Motion

Momentum | Thermal | Radiation | Species| DPM | Mutiphase | UDS | wall Fim |

@ Stationary Wall

| [V]Relative to Adjacent Cell Zone |

) Moving Wall

Mo Slip

() Specified Shear
Specularity Coeffident
Marangoni Stress

Wall Roughness

Roughness Height {m) ” 0

|constant - |

Roughness Constant ” 0.5

|c0nstant - |

[Coc )] @) (oo

as per below and click OK.

Meshing
Mesh Generation
Solution Setup

General
Models
Materials
Phases

Dynamic Mesh
Reference Values

Solution
Solution Methods
Solution Contrals
Monitors
Solution Initialization
Calculation Activities
Run Calculation
Results
Graphics and Animations
Plots
Reports

Boundary Conditions

Operating Conditions

Zone

Gravity

axis
inlet
interior-surface_body

Operating Pressure
97225.9

scal)

0

Reference Pressure Location

x'[l'ﬂ}‘u

Y{m}l|u

Z (m) |||;|

Gravity

Phase Type D
|mixb_|re v“wall v] |5
Edit. Copy... Profiles...

Display Mesh... | Periodic Conditions. .. |

L e e

Solution Setup > Boundary Conditions > Operating Condition. Change parameters
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6.12.

6.13.

below.

Solution Setup > Reference Values. Change parameters as per below.

Axis Boundary Condition
Variable u(m/s) | v(m/is) | P (Pa)
Magnitude - 0 -
Zero Gradient Y N Y

Meshing
Mesh Generation
Solution Setup

General

Maodels

Materials

Fhases

Cell Zone Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values

Solution

Solution Methaods
Solution Controls
Maonitors

Solution Initialization
Calculation Activities
Run Calculation

Results
Graphics and Animations

Plots
Reports

Boundary Conditions

Zone

inlet

interior-surface_body

outlet

wall

Fhase T (]
mixture aKis - |?
[ Edit... ] [ Copy... ][F‘ruﬁles... ]

[ Parameters... ] [Dperaﬁng Cundiﬁuns...]

Display Mesh... | | Periodic Conditions. ..

Solution Setup > Boundary Conditions > axis. Make sure that axis is selected as per

18



Meshing Reference Values

Mesh Generation Compute from

Solution Setup [

General Reference Values

Models

Materials Area (m2) | 0.002154869
Phases

Cell Zone Conditions

Density {kgfmS} | 1.17
Boundary Conditions

Mesh Interfaces Enthalpy (j/ka) | 0
Dynamic Mesh

Length {m) | 0.05233

Solution

Solution Methods Pressure (pascal) | 0
Solution Controls

Monitors Temperature (k) | 298.16
Solution Initislization

Caloulation Activities Velodty (m/s) | 0.2
Run Calculation

Results Viscosity (kg/m-s) | 1.872e-05
Graphics and Animations

Plots Ratio of Spedfic Heats | 1.4
Reports

Reference Zane

[

Help

7. Solution

7.1. Solution > Solution Methods. Change parameters as per below.

Meshing Solution Methods
Mesh Generation psssucaVelocity Counling
Solution Setup o
General [SIMPLE
Models
Materials spatial Discretization
Phases
Cell Zone Conditions Gradient
Boundary Conditions [GFEEH-GEUSS Cell Based "'l
Mesh Interfaces Pressure
Cynamic Mesh [Seoond Order vl
Reference Values Momentum
Solution [Second Order Upwind "'l
olution Methods
Solution Controls
Maonitors

Solution Initialization
Calculation Activities
Run Calculation

Results
Graphics and Animations
Plots
Reports

Transient Formulation

Mon-Iterative Time Advancement
Frozen Flux Formulation

Pseudo Transient

["|High Order Term Relaxation
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7.2. Solution > Monitors > Residuals —Print, Plot > Edit... Change convergence criterion to le-
06 for all three equations as per below and click OK.

Meshing
Mesh Generation
Solution Setup
General
Models
Materizls
Phases
Cell Zone Conditions
Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values
Solution
Solution Methods
Solution Controls
Solution Initizlization
Calculation Activities
Run Calculation

Monitors

Residuals, Statistic and Force Monitors

Residuals - Print, Plot

Statistic - Off

Delete

Surface Monitors

Edit... | | Delete

Volume Manitors

Options

Residual Mo_ni_

=

Equations

[ compute Local Scale

[]Print to Consale Residual Monitor Check Convergen&% -
Plot continuity 1e-06
RATEE - *-velodity 1e-06
8 r——
Iterations to Plot ey 1o b
1000 % Residual Values Convergence Criterion
[ Normalize Iterations absolute
5 r
Iterations to Store =
1000 % Scale

-

[ o J|( por ) (Renomaise] [ comcd ) [ e

7.3. Solution > Solution Initialization. Change parameters as per below and click Initialize.

Meshing
Mesh Generation
Solution Setup

General

Models

Materials

Fhases

Cell Zone Conditions

Boundary Conditions

Mesh Interfaces

Drynamic Mesh

Reference Values
Solution

Solution Methods

Solution Controls

Monitors

olution Initialization
Calculation Activities
Run Calculation

Results

Flots
Reports

Solution Initialization

Graphics and Animations

(") Hybrid Initislization

@ Standard Initialization

Compute from

Reference Frame

@ Relative to Cell Zone
() Absolute

Initial Values
—

Gauge Pressure (pascal)

0

Axial Velodty (m/s)

0.2

Radial Velodty (m/s)

0

Reset DPM Sources

I Initialize I[ Reset |[Patch... |

Reset Statistics
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7.4. Solution > Run Calculation. Change Number of Iterations to 1000 and click Calculate.

Meshing ° Run Calculation
Mesh G i
S Eneraten [ Check Case... ] | Preview Mesh Motion. .. |
Solution Setup
General MNumber of Iterations Reporting Interval
Models 1000] | 1 &)
Materials | | =
Phases Profile Update Interval
Cell Zone Conditions 1
Boundary Conditions 2]
Mesh Interfaces — -
Dynamic Mesh [ Data File Quantities... ] | Acoustic Signals...
Reference Values
Soton

Solution Methods
Solution Controls

Monitors

Solution Initislization
Calculation Activities
Run Caloulation|

Results
Graphics and Animations
Plots
Reports

7.5. Once the solution converges, click OK. (The residuals should be comparable to the ones

Sealed Residusls. 44209, 2013
AMEYE Floard 145 funs, dp, pbk_ lam)

548 1.0203¢-! «F069e-
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Shh 1. 177Te- 2420
A 995 1A i
Skt 1,180 Trute
47 i | Do
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i
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i
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NOTE: ANSYS determines when to stop a calculation based on the iteration number and
convergent limit you specified. If: 1. The maximum iteration number is reached, but convergent
limit is not reached, or 2. Convergent limit is satisfied, but maximum iteration number is not
reached, ANSYS will terminate the computation.

File > Save Project. Save the project
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8. Results

Please read exercises before continuing.

8.1. Displaying Mesh
Display> Mesh. Select all Surfaces you wish to be visible and select Display then click

Close.
Displ Report  Parallel Wi Hel — .
I hdesh...

Graphics and Animations.., r Options Edge Type

Plats... Nodes @ Al axis

Residuals.. [] Edaes () Feature !I"I|E_tl .
. ) Outiine |nt§r|c|r—:‘uri—nCc_I:ucu:I\-I

Options... [T Partitions f::;"Et

Scene.. i

] Shrink Factor ~ Feature Angle

Wiews,.,
R »

Lights...

Colormap... Surface Name Pattern

Annotate... | Match

Surface Types

Zone Maotion... N n
m:m -lntemr axXis

DTRM Graphics... - - dlip-surf

Irnport Particle Data.., ef::aust—ﬁn

PDF Tables/Curves..,

Reacting Channel/Curves...

Mouse Buttons... M [colors... | [ Close | [ Hep |
—— —— e = = W

Zoom in to the inlet by usng the magnifying glass with a plus sign in the middle of it.
The mesh should look like the one below.

8.2. Saving Pictures
To save a picture of the screen, select File > Save Picture... Make sure all the parameters

are set similar to the ones below and click Save... (To preview the picture, before you save
click Preview in the Save Picture window)

- N
Save Picture ‘ g

Format Coloring File Type Resolution

0 EPS @ Color (@) Raster Width =

= 960
() Gray Scale Vector =
s (7) Monochrome Height IW &
=

Options
Landscape Orientation ‘indaw Dumnp Command
Window Dump | | [¥] White Backaround || import -window % |
I Save... I[An:iv ] [Preview] [E‘rose ] [ Help ]
|
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Name the File as CFD Pre-Labl Laminar Pipe Flow Mesh, navigate to the CFD Pre-Lab 1 file you

created and save it in that file. Then close the Save Picture window.

S =
- @ E

| Date modified

r
Select File

Lookin: |, CFD Pre-lab 1

| Name Type

(4=

<>
Recent Places
|
Desktop
=
Libraries
§ ™
LY

Computer

@ g

MNetwork
l OK I

[ Concd ]

Mo items match your search.

CFD Fre-Lab 1 Meshlipg A

Hardcopy Files -

Hardcopy File

Files of type:

— ¥

8.3. Displaying and Saving Residuals
To display the residuals click Solution > Monitors > Residuals — Print, Plot > Edit... >
Plot then click Cancel.

A:CFD Prelab 1 Laminar Flow Fluent [axi, dp, pbns, lam] [ANSYS Academic Teaching Advanced]

A

== = |
g =B K

|F”E Mesh Define Solve Adapt S-urfaca Display Report Pa:allel \f_\ew Help

BE-d-me s ea@s @m0

Meshing

Solution Setup
General
Models
Materials
Phases
Cell Zone Conditions
Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values
Solution

Solution Methods
Snleiisssiignirols

. tialization
Caloulation Activities
Run Calculation

ResLlts
Graphics and Animations
Plots
Reports

Monitors

Mesh Generation [

S ST

1 Delete

Surface Monitors

Create

1e.05
1e05
1e-07
Create... | |Edit.. | | Delete
Volume Monitors
1e-09
a 100 200 300 400 500 &00
lterations
a Residual Menitors u
- Options Equations Jul 28, 2013
oy Print to Console Residual Manitor Chedk Convergence Absalute Criteria - dp, phns, lam)
] Piot STy 1e08 00:32 46|~
o _ e i =¥
1 H
8 o e e 2
3 Iterations to Plot o g1:88 a5
Congl 1000 % Residual Values Canvergence Criterion gg !3': ::g
Mormalize Iterations [Hasolute '] B08:38 45
I \|5—, =] o1:55 us
Iterations to Store = Eo1:32 a5
1000 % Scale lko1:13 us5
Compute Local Scale timesite
B0:58 A4
ae:47 hh
00:37 i
80:38 B4
o e- o e o e 1@1:53 44
556 8.3473e-07 1.0269e-06 1.5870e-00 0:01:30 44 |
LL7 8.2P04Be-07 1.013%e-86 1.5691e-09 6:81:12 4h| -
< | 1 ] v

You can save this picture the same way you saved the mesh. Name it CFD Pre-Lab 1
Laminar Pipe Flow Residuals History and save it to the folder you created on the H: Drive.
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8.4. Plotting and Saving Results
To plot results, click Results > Plots > XY Plot > Set Up...

To plot the Centerline Pressure Distribution, copy the parameters as per below and click
Plot.

=

File Mesh Define Solve Adapt Surface Display Report Parallel View Help

N DR LTS

Meshing | Plots
Mesh Generation
General F'IIS ram
ile
Model.s I Profiles:
Materials Frofile Data - Unavailable
Phases Interpolated Data
Cell Zone Conditions FFT

Boundary Conditions

Mesh Interfaces

Dynamic Mesh

Reference Values
Solution

I Solution Methods
Solution Controls

Monitors 15T

Solution Initialization

Calculation Activities 500202
Run Calculation SetUp... "
Results 0.00e+00
. . 0 1 2 3 4 5 [} 7 8
plics and Animations L
H‘*’ Pasition (m)
—

b

Solution XY Plat

Options Plot Direction f’ Axis Function 129 2013
[¥] Node Values X1 Pressure... bns larm)
Position on X Axis -

[JPosition on Y Axis | | Y g [S‘thpfes € he| -
Write to File X Axis Function y5
[] order Points Z || 0 | [D{Edim Vector 45
45
File Data B8] 45

inlet
interior-surface_body
outlet

wall

Load File... fite

[New Surface » ]

| Free Data |

=
=
4

1.5691e-89
| >

1.813%-06
1]

557 8.204Be-07

Save the picture as you did for the mesh and call it CFD Pre-Lab 1 Laminar Pipe Flow
Centerline Pressure Distribution and save it in the folder you created.
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To plot Centerline Velocity Distribution, copy the parameters as per below and click Plot.

L

>
3 A:CFD Pre-Lab 1 Laminar Pipe Flow Fluent [axi, dp, pbns, lam] [ANSYS Academic Teaching Advanced]

File Mesh Define Solve

Adapt Surface Display Report Parallel View Help

A Es-d-me S[Haa s @lnmE-o-

Meshing
Mesh Generation
Solution Setup
General
Models
Materials
Phases
Cell Zone Conditions
Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values
Solution
Solution Methods
Solution Controls
Manitors
Solution Initialization
Calculation Activities
Run Calculation
Results
Graphics and Animations
o]
Reports

Plots

Plots.

Histogram

File

Profiles:
Profile Data - Unavaiable
Interpolated Data

FFT

226001

2.00e-01

1.75e-01

Auial Vel |

Solution XY Plot

Position ()

Options ot Direction

¥ Axis Function

Node Values X
Position on X Axis
[] Position on ¥ Axis
Write to File

B (==
O [l velocity
B X Axis Function

[[] order Points Z ” )

| Direction Vector

File Data 8E

Free Data

New Surface ¥

Qct10, 2013
'S Fluent 14.5 (axi, dp, pbns, lam)

atavDesktop\Intro CFD |

r

Save the picture as you did for the mesh and call it CFD Pre-Lab 1 Laminar Pipe Flow
Centerline Velocity Distribution and save it in the folder you created.
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To plot the Wall Shear Stress Distribution, copy the parameters as per below and click Plot.

-
4CFD Pre-Lab 1 Laminar Pipe Fiow Fluent [, dp, pbns, lam] [ANSYS Academic Teaching Advanced] (=l=2] = |

File Mesh Define Solve Adapt Surface Display Report Parallel View Help ‘

Bs-rd-me)sHaasfeainEm-o-

s

Meshing Plots
Mesh Generation Plots
Solution Setup b
General Histogram
Models Fie
" Profiles:
Materials Profile Data - Unavailable
Phases Interpolated Data
Cell Zone Conditions FFT

Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values

Solution
Solution Methods
Solution Controls

r' Monitors

Solution Initialization

Calculation Activities
Run Calculation SetUp... 5 D0e-0d

Results [ 1 z 3 4 5 ] 7 8
Graphics and Animations

| | Reports Solution XY Plot

1.002-03

oct10, 2013
[#] Node Values AMNSYS Fluent 14.5 (axi, dp, pbns, lam)
[7] Position on X Axis
[ Position on Y Axis
[ wirite to File

[[]order Points

File Data EE

N

|
ll !!![Am--] [curves... | [ Cose | [ reb | M

< m 3

Save theﬁtﬁre as you did for the mesh and call it CFD Pre-Lab 1 Laminar Pipe—FIow
Wall Shear Stress Distribution and save it in the folder you created.
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To plot Profiles of Axial Velocity at All Axial Locations with AFD Data, click File > Read
> Journal. Navigate to the folder you created, change Files of type to All Files and select

Intro CFD Lab 1 Journal. Once selected click OK, when the Question window pops up

select No. This journal creates lines at different locations along the pipe axis where velocity

profile data is extracted.

B ACFD Pre-Lab 1 Laminar Pape Flow Fluent fas. . b, lam] [ANSYS Acader Teacking Advanced]
[File Mesh Define Sohe Adapt - Surface Duplay Report Pacallel View Helg

@l -d-w@ s+ GEs R E-0

Meshing _Graphics and Anlmations
Mesh Beneraten Graghics
Soluton St e ]
Gerernl ;Ovm.n
Mook riy
[Patines
Mbjuris |t Teacks
Gl Zone Condinine I
Goundary Condtors
Pach inter! | st
Dnamic Mesh
Foeference Yalues
Sohitery
‘Solution Methods:
‘Solustion Controls
Moritors
Soiuton Ivtalzabon
Caindaton Acmites
Fun Cacutaton: | I
Resuss [setup... |
Jiraetecs v rumatora}
Pty
Reperts Optors.... | Scene... | [ vewt...

i T
0 Boss the fourmal fie contan commands St
read o wrte fles after the caiculaton begns?
=]
—— —

esh

ANEYE Fluged 145 [, dp, pbes, k)

> {cx-qui-da cx-activate-item “Line/Rake Sur [l b ]

» {cx-gui-de cx-set-text-entry “Line/Rake SurfacesTextCntryt(Hew Surface Hame)" “x=18@d")

¥ {cx-gui-do cx-set-real-enbtry-1ist “Line/Rake SurfacesFraneh{End Points)eFramei=Tablel=Rea

¥ {ex-gui-ge cx-set-real-entry-list “Line/Bake Surfacesfraned(End Points)sfranet=lablel=ges

* {ex-gui-da ex-activate-iten “Lines S

3 {ex-qgui-do cx-activate-iten “Line/Rake Sur

Click Results > Plots > XY Plot > Set Up... Click Load File... and select

axialvelocityAFD-laminar-pipe.xy, which can be found from the class website. Click OK.

-

Solution XY Plot

i »

Options Plot Direction ¥ Axis Function
Mode Values X[y [Waﬂ Fluxes... v]
Position on ¥ Axis . -
["|Position on ¥ Axis Y g [E‘.lun Friction Coeffident "]
Write to File ¥ Axis Function
[l order Paints z | 0 [Direchon‘ Vector ']
File Data EE Surfaces BE
inlet -

interior-surface_body

outlet
|

x=100d

x=10d
x=20d
Load File x=40d ¥
[ Free Data ] [New Surface » ]

[ Flot ] [Mes...] [Curves...] [ Close ] [ Help ]

————— —_—
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Change Parameters as per below. Make sure to select inlet as well.

File Mesh Define Solve Adapt Surface Display Report Parallel View Help

A E-d-me) SHaasielnm-o-

Cell Zone Conditions
Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values
Solution
Solution Methods
Solution Controls
Monitors
Solution Initialization
Calculation Activities

Meshing Plots
Mesh Generation Plots
Solution Setup XY Plot
General Histogram
Models e
Matoril Frofiles:
aterials Profile Data - Unavailable
Phases

Interpolated Data
FFT

O0e-|

1.80e-01

Options

Node Values

Position on X Axis

[]Position on ¥ Axis

Write to File

Run Calculation SetUp... i .
Results P “a
N . -
Graphics and Animations -
lot) .
Reports 5.00e-02 2
0.00e-+10 =
0.015 002 0.025 0.03
Solution XY Plot Position (m)
I

Oct 10, 2013
ANSYS Fluent 14 5 (a4, dp, pons, lam)

File Data EE

Velocity Magnitude

New Surface »

o] [curves...] [[Close | [ nep |

ace=Frame4(End Points)=Frame1+Tablei=RealEntryl(

nelButtons*PushButton1(0K)")

nelButtons*PushButton2({Cancel)")

*Stop Journal®)

A

Click Curves... > Change the Pattern to the pattern seen below and click Apply. Incriment the

Curve # by one and repeat. Do this for curves 0 through 7 then click Close.

(B solution XY Plot % |
Options Plot Direction ¥ Axis Function
m— J— -
) Curves - Solution XY Plot —. | [
L]
| Curve # Line Style Marker Style
[] l‘T = Pattern Symbol
=] 2 ym
File Sample ’_ v] [ﬁ ']
I Calor Color
lfmegou:d v] [ﬁ:xegm:d v] |
VWeight Size
| 1 |0.3

28



Click Plot.

File Mesh Define Solve Adapt Surface Display Report Parallel

B s-d-me SEaasfaliEyo-

View Help

Meshing Plots
Mesh Generation

Solution Setup t
General Histogram

File
Models Profiles:

Materials Profile Data - Unavailable
Phases Interpolated Data

Cell Zone Conditions FFT

Boundary Conditions
Mesh Interfaces
Dynamic Mesh
Reference Values

Solution
Solution Methods
Solution Contrals
Manitars
Solution Initialization
Caloulation Activities
Run Caleulation SetUp...
Results

Graphics and Animations

1.80e-01

1.00e-01

5.00e-02

0.00e+00 s
0 0.005 0.1 0015 002 0.025 003

Position (m)

E

Solution XY Plot

Tun ¥ Axds Function
[¥] Mode Values X o [!Iekmty -]
Position on ¥ Axis
[_|Position on ¥ Axis | | Y
Wirite to File
[l order Points z

Fiie Data EE
Velocity Magritude

:

1]
§
:

Oct 10,2013
ANSYS Fluent 14 5 (a4, dp, pbns, lam)

set-real-entry-1list “Line/Rake SurfacexFrame4(End Points)=*Framei=Tabled*RealEntryi(

activate-item “Line/Rake Surface=PanelButtons*PushButtoni{0K)")

=

FreeData New Surface ~
([Crot [l wes. | [cuves..] [cose | [(rep |

activate-item “Line/Rake Surface=PanelButtons*PushButton2({Cancel)}")

activate-item "MenuBarxWriteSubHenuxStop Journal")

4 [l

< " | r

Save the picture as you did for the mesh and call it CFD Pre-Lab 1 Laminar Pipe Flow
Axial Velocity at All Axial Locations with AFD Data and save it in the folder you created. Close
the Solution XY Plot window.
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8.5. Plotting and Saving Graphics
Click Results > Graphics and Animations > Vectors > Set Up...
To plot the velocity vectors at the region flow begin to becomes fully developed, copy the
parameters as per below and click Display. Zoom into the region where the flow is almost
fully developed.

File Mesh Define Solve Adaspt Surface Display Report Parallel View Help
O E-hd-me SRR s @ L0

Meshing Graphics and Animations

1: Velocity Vectors Colored B =

Mesh Generation Graphics
Solution Setup Mesh

General

Models

Materials

Phases

Cell Zone Conditions
Boundary Conditions
Mesh Interfaces SetUp...

Dynamic Mesh
Scene Animation
Solution Animation Playback

Reference Values
Vectors

Solution
Solution Methods
Solution Controls
Monitors

Solution Initialization
Calculation Activities
Run Calculation

Options

Global Range
Auto Range

[ Clip to Range
Auto Scale
Draw Mesh

Max (mfs)
‘ H 0.3994212

Oct 10, 2013
ANSYS Fluent 14 5 (a4, dp, pbns, 1am)

A

Surface Name Pattern
-1list “Line/Rake SurfacexFrame4(End Points)=Frame1=Table1=RealEntryk(

Surface Types EE

axis « | f "Line/Rake SurfacexPanelButtons=PushButtoni1({0K)")
clip-surf

exhaust-fan

fan s if "Line/Rake SurfacexPanelButtons#PushButton2{Cancel}")

| o | o] [ ) [ ]

‘I “"MenuBarxWriteSubMenuxStop Journal") |:

Save the picture as you did for the mesh and call it CFD Pre-Lab 1 Laminar Pipe Flow
Velocity Vectors at the Region Flow Begins to Become Fully Developed and save it in the folder
you created. Close the Vectors window.
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Click Results > Graphics and Animations > Contours > Set Up...
To plot the Contours of Radial Velocity, copy the parameters as per below and click
Display. Zoom in to the pipe inlet to see the contours of radial velocity.

e Mesh Define  Sohe Adept  Surfece Daply Repomt Parafiel  View  Help
B G-d-m@ DR e s & 8

Meshirg (Graphics and Animations

hases

Oct 10, 2013
ANSYS Fluent 145 (24, dp, pbns, |am)

Geaf FacesFranen(End Points)sFraneisTableisRealEntryh(
= ne 1But tanssPushiut tont (0K} )
Cone | [ v |_

. = = —

» (ex-gui-do cx-activate-item “HenubarsWriteSubMenusStop Journal®™)

Py Cancel)”)

Save the picture as you did for the mesh and call it CFD Pre-Lab 1 Contours of Radial
Velocity and save it in the folder you created. Close the Contours window.

8.6. Exporting Results
To export Results, click Results > Plots > XY Plot > Set Up...
To export the Developed Axial Velocity Profile at x=100d, copy the parameters as per
below and click Write...

Solution XY Plot = |

Qotions Plat Direction ¥ Axis Function

Mode Values X [a ['u'elodty. » —
Position on X Axis - -

[] Position on ¥ Axis ¥ ’17 [Amal biclosiiy i
Write to File X Axis Function

Order Points z ” 0 ‘ | Direction Vector -

File Data EE

Load File...

[ Free Data l [New Surface = l

I[Write... [AJ:ES...] [Curves...] [ Close ] [ Help ]

Name the file CFD Pre-Lab 1 Laminar Pipe Flow Developed Axial Velocity Profile and
leave the Files of Type: as XY Files. Click OK.
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Select File

T

Look in . CFD Pre-Lab 1

- @M

b
Recent Places @
Desktop ialvelocityAFD- ..
=r
Libraries
A
Computer
w
Netwark
XY Fie CFD Pre-Lab 1 Developed /il Velocty Profie =
Files of type [XY Files v] [ Cancel ]

To export the wall shear stress distribution, copy the parameters as per below and click

Write...
- =
Solution XY Plot _ [
Opfions Plat Direction Y Axis Function
Mode Values X lil [Wall Fluxes... -
[¥] Position on X Axis
Position an Y Axis Y lgi [Wall Shear Stress i
Wirite to File ¥ Axis Function
[ Order Points 2o Direction Vector -
File Data EE
inlet
interior-surface_body
outlet
Load File... i
Free Data |
[ Write... ] [ Axes,.. ] [Curves...] [ Close ] [ Help ]

Name the file CFD Pre-Lab 1 Laminar PipeF_Iow Wall Shear Stress Distribution and leave
the Files of Type: as XY Files. Click OK. Close the Solution XY Plot.

File > Save Project. Save the project and close the Fluent window.

8.7. Normalizing Velocity Profile
e Open excel from Start Menu.
e Click File > Open, navigate to your folder you created on the H: Drive.
e Change the file type to all files.
o Select the file CFD Pre-Lab 1 Laminar Pipe Flow Developed Axial Velocity Profile
and click Open.
e Select Yes on the Microsoft Excel message.

Microsoft Excel

==y

The file you are trying to open, 'CFD Pre-Lab 1 Developed Axial Velodity Profile’, is in a different format than specified by the file extension. Verify that the file is not corrupted and is from a trusted
JL source before opening the file, Do you want to open the file now?

Was this information helpful?

o Make sure delimited is selected and click Next>.
e Make sure that Tab and Space Delimiters are checked and hit Einish.
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Text Import Wizard - Step 2 of 3 [

Thig screen lets you set the delimiters your data contains. You can see how your text is affected in the preview
below,

Delimiters

[ semicolon V] Treat consecutive delimiters as one

Comma
Oc Text gualifier: |~

Space |Z|
[ other:

Data preview

(title izl Velocity)
({lzbels osition izl Velocity)

{ (xy/key/label k=100d)
393408 <
4 3

| Cancel || <gack || pext> J§ [ Fnish |

e In Cell C5 enter the formula as seen in the Formula Bar below. Then take the fill
handle and drag to the end of the data. This normalizes the velocity profile from the
max velocity.

= e ]

PR [

Home Insert Page Layout Formulas Data
Tl & cut Calibri 11 v A =
o L= AT — - A=
aste - Ll ow - - =
+ < Format Painter H Ul = - =

Clipboard 1 Fant

cs - f | =B5/SBS5

A B C Fermula BarE
1 |(title Axial Velocity)
2 (labels Paosition Axial Velocity)
3
4 |((xy/key/label x=100d)
5 0 D.399408I 1.|
8 0.000582 0.399309
7 0.001164 0.39872

N oN174R n 397739

Insert a Scatter Plot With Smooth Lines and Markers.

For the x-axis use the radial position, and for the y-axis use the normalized velocity.

Name it CFD Velocity Profile (Laminar).

You can move this plot to a new tab by clicking on the chart Chart Tools > Design

> Move Chart Location > New Sheet > OK

e Next open the file Normalized-velocity-AFD-laminar-pipe.xy in TextPad, highlight
the data and paste it into your Excel spread sheet next to the CFD velocity profile
data.

e Plot this in the same way as the other set on the existing plot and call this AFD
Velocity Profile (Laminar).

e Create axis titles and make sure the legend is shown. You should move the legend to
the bottom of the chart. Call the axes Normalized Veloctity [-] and Radial Position
[m].

e Save this Sheet by selecting File > Save As, name it CFD Pre-Lab 1 Developed

Axial Velocity Profile.
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9. Exercises

You must complete all the following assignments and present results in your CFD Lab 1
reports following the CFD Lab Report Instructions.

Simulation of Laminar Pipe Flow
e You need use CFD Lab1l Report Template.doc to save all the figures and data

1. Compare CFD with AFD on friction factor

Use the instructions to generate the mesh and setup then iterate the simulation until it converges.
Find the relative error between AFD friction factor (0.097747231) and friction factor computed by
CFD, which is computed by:

Factor, ., — Factor,.,
Factor,g,

x100%

To get the value of FacCtor.. , you need first write to file the wall Shear Stress Distribution. Then

use EXCEL to open the data file and pick the value close to the pipe exit or inside the fully
developed region. Next use the equation C=8*t/(p*U"2) to solve for the Friction Factor. Where C
is the friction factor, t is wall shear stress, p is density and U is the inlet velocity.

e Figures need to be saved: 1. Residual history, 2. centerline pressure distribution, 3. centerline
velocity distribution, 4. Wall shear stress distribution, 5. profiles of axial velocity at all
streamwise locations (x/D=10,20,40, 60,100) with AFD data, 6. contour of radial velocity, and
7. velocity vectors (pick up the region where flow begins to become fully developed).

e Data need to be saved: shear stress in the developed region, developing length. Here,
developing length is defined as the length from pipe inlet to the axial location where the
centerline velocity does not change any more.

2. Normalized developed axial velocity profile
2.1. Export the axial velocity profile data at x=100d following the instructions in Step 8.6.
2.2. Use EXCEL to open the file you exported and normalize the profile using the
centerline velocity magnitude, which is the maximum value on that profile. Plot the
normalized velocity profile in EXCEL and paste the figure into WORD, together with
other figures you made in Exercise 1.

3. Questions need to be answered when writing CFD Lab 1 report
3.1. Can you use centerline pressure distribution to determine the “developing length”?
Why?
3.2. What is the value for radial velocity at developed region?
3.3. Summarize your findings in CFD Lab report and try to relate them to your classroom
lectures or textbooks.
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