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1. Purpose

The Purpose of CFD PreLab 2 is to simulate turbulent flow around a Clarky airfoil following the “CFD
process” with an interactive step-by-step approach. Students will have “hands-on” experiences using ANSYS
to compute pressure, lift and drag coefficients using both viscous and inviscid models. Students will
validate simulation results with EFD data measured at EFD Lab 3, analyze the differences and possible
numerical errors, and present results in Lab report.
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Flow chart for “CFD Process” for airfoil flow




2. Simulation Design

In EFD Lab 3, you have conducted experimental study for turbulent flow around a ClarkY airfoil
(Re=300,000) for two angles of attack 0 and 16 degrees. The pressure on the foil surface you have measured
will be used for CFD PreLab 2. In CFD PreLab 2, simulation will be conducted under the same conditions of
EFD Lab 3 (geometry, Reynolds number, fluid properties) at angle of attack O degree using both viscous and
inviscid models. Simulation results will be validated by your own EFD data.

The problem to be solved is turbulent flow around the ClarkY airfoil with angle of attack (o)

Table 1 - Geometry dimensions

Parameters Symbol Unit Value
Chord Length C m 0.3048
Domain radius Rc m 6
Angle of attack o m 0

Figure 1 — Geometry



3. Open ANSYS Workbench

3.1. Start > All Programs > ANSYS 16.2 > Workbench 16.2
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3.2. From the ANSYS Workbench home screen (Project Schematic), drag and drop a Geometry, Mesh,
and Fluent component from the Component Systems drop down menu onto the Project
Schematic. The Project Schematic should resemble the schematic below. Rename the components

as per below.
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3.3. Create a Folder on the H: Drive called CFD Pre-Lab 2.

3.4. Save the project file by clicking File > Save As...

3.5. Save the project onto the H: Drive in the folder you just created and name it CFD Pre-Lab 2
Turbulent Flow.

4, Geometry
4.1. Right click Geometry then select Import Geometry > Browse... Select intro_airfoil.igs and click
OK.
4.2. Right click Geometry and select Edit Geometry in DesignModeler...
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4.3. Click Generate to generate the airfoil geometry.
4.4. Select XYPlane and click New Sketch button.
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4.5. Select the sketch you created and click Sketching button.
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4.6. Sketching Toolbox > Draw > Circle. Click on the xy-plane origin, “P” should pop up when you are
on the origin, and click off, encapsulating the airfoil geometry. (Click z-arrow at right bottom to

change the view as perpendicular to xy plane)




4.7. Sketching Toolboxes > Dimensions > General. Click on the circle and change the diameter to 12m.
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4.8. Select the Modeling tab. Concept > Surfaces From Sketches. Select your sketch, click apply in the
Details View for Base Objects, and click the Generate button.

File Create Concept Tools View Help

2] = [ | *= Lines From Points elect:,_ T~ | f

J
laH A
J XfPlane 2 Lines From Sketches
|+ Generate
J

} Generate [ Lines From Edges

ers Extrude
4, 30 Curve - |J ® - T
& Thin/Surf “ Split Edges Slice |J Q Point @,
Tree Outline 7

= ,@ A G A

Surfaces From Faces

Cross Section L4
...... ik

------ » :*. YZPlane
...... v Curvel
...... v i BodyOpl
...... T BodyOp2
T BodyOp3
------ v s EdgeSplitd
------ v = EdgeSplits
------ % EdgeSplith




4.9. Create > Boolean. Change operation to Subtract then select the circle for Target Bodies then
select the airfoil (click on the airfoil until only the airfoil’s color turns yellow) for Tool Bodies and
click Generate. This will subtract the airfoil surface from the circle.
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4.10. Concept > Split Edges. Select the perimeter of the circle, make sure the Fraction is 0.5, and
click Apply. Select Generate. This should split the circle into two semicircles. You can see the
semicircles by selecting the perimeter above and below the x-axis.




4.11.

Repeat the process from 4.9 on the two semicircles. This should yield four circular quadrants.
4.12.

Concept > Lines From Points. Draw a line from the point on the circle to the point on the
airfoil making sure to hold Ctrl while doing so. (Note: The point on the front part of the airfoil is not
exactly on the origin, you need to make sure to select the point on the airfoil and not the origin.
Zoom in and find the point just below the origin and select that point. The images below show the
locations of the points circled. When selecting points to generate lines with, be sure to select the
point on circle and then the point on the airfoil as to avoid complications when sizing mesh).
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Once you select both points hit Apply. Then click Generate.

4.13.



4.14. Repeat this process creating lines from the edge of the circle to the airfoil starting from the
circle and ending at the airfoil (A to A’, Bto B” and C to C’). The images below show the locations

of the points on the airfoil and the points on the circle.
' ANSYS

4.15. Tools > Projection. Select the four edges you created for Edges and click Apply then select
the domain circle for Target and click Apply, then click Generate. This will split your geometry
into four sections.
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4.16. File > Save project and exit.




5. Mesh Generation
5.1. From Workbench home screen right click on Mesh and select Edit... from the dropdown menu.
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5.2. Right click Mesh then Insert > Face Meshing. Select the four surfaces while holding Ctrl then click
Apply.
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5.3. Right click Mesh and Insert > Sizing. Make sure to change the selection tool to edge and select two
edges as per below an_d change the parameters as per below.
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5.4. Right click Mesh and Insert > Sizing. Select two edges as per below and change the parameters as

per below.
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Details of "Edge Sizing 2" - Sizing
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5.5. Right click Mesh and Insert > Sizing. Select all for lines leading from the circle to the airfoil
surface, and click Apply. Change parameters as per below. (Note: If you did not create the lines
starting from the outer circle and ending on the airfoil surface, you may have issues with biasing. If

this is your case, size the lines individually making sure that the sizing is finest at the surface of the
airfoil.)
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5.6. Right click Mesh and Insert > Sizing. Select the surface at the top of leading edge of the airfoil and
click Apply. Change Parameters as per below.
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5.7. Right click Mesh and Insert > Sizing. Select the surface at the bottom of leading edge of the airfoil
and click Apply. Change Parameters as per below.

Details of "Edge Sizing 5" - Sizing
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5.8. Right click Mesh and Insert > Sizing. Select the surface at the top of trailing edge of the airfoil and
click Apply. Change Parameters as per below.
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5.9. Right click Mesh and Insert > Sizing. Select the surface at the bottom of trailing edge of the airfoil
and click Apply. Change Parameters as per below.
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5.10.
Preference, change the mesh type to CFD from Mechanical.
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5.11.
resembles the mesh below.
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5.12. Hold Ctrl and select the two left most semicircle arcs, right click on them and select Create
Named Selection, name the selection inlet. Use the edge select button from the toolbar.
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5.13. Do the same for the two right most semicircle arcs and name them outlet.
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5.14. Select the four regions that make the airfoil, right click and Create Named Selection and
name it airfoil.
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5.15. Now use the face button to select the four semicircle quadrants and Create Named Selection
and name them fluid.
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5.16. File > Save Project. Exit the window

6. Setup (Physics)

6.1. If there is not a checkmark next to Mesh, right click Mesh, and click the Update.

6.2. From the Workbench home screen right click on Setup and select Edit...
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6.3. Select Double Precision and click OK.
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6.4. If this note pops up, click OK

Information

Mote: 2d, pressure-based, laminar case read into
2d, double predsion, pressure-based, laminar solver.

6.5. Setup > Models > Viscous —Laminar > Edit... Change the parameters as per below and click OK.
(For the inviscid case, select Inviscid from the Viscous Model menu.)
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6.6. Setup > Materials > air > Create/Edit... Change parameters as per experimental data and click
Change/Create and then Close. (For inviscid model, you do not need to input Viscosity parameter)
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Use the air properties at the room temperature when you conducted EFD Lab3. You can use the following
website to calculate air properties from the temperature:
http://www.mhtl.uwaterloo.ca/old/onlinetools/airprop/airprop.htmi

The values in the figure above are for 24° temperature.

NOTE: viscosity used in ANSYS is the dynamic viscosity (kg/m-s), NOT kinematic viscosity (mz/s)

6.7. Setup > Boundary Conditions > inlet > Edit... Change parameters as per experimental data (blue
box) and default values (red boxes) and click OK. The experimental value can be found from the
EFD Lab 3 data reduction sheet. (For inviscid model you do not need to specify turbulence
parameters.)

C:Viscid Fluent@L-COE211.engin.uiowa.edu [2d, dp, pbns, ske] [ANSYS Academ| Velocity Inlet

File Mesh Define Solve Adapt Surface Display Report Parallel View | zone Name
85 050/ SEAR @180 |/ [|n

=g Setu iti
@. = o el HoundarylGonditions Momentum | Thermal | Radiation | Species | DeM | Muitiphase| ups |

Z
BY Models L2 Velocity Spedification Methodf components

S oo e |
Reference Frame
INTErIor =TIl b

Bou ndary Conditions outlet
Supersonic/Initial Gauge Pressure {pascal) [ _
surface_body constant

Q Reference Values
¥-Velodity (m/fs)
B rE Solution '15 constant -

EJ Results ¥-Velodity (m/s) | 0 constant -

H-8h Parameters & Customizatic

Turbulence

i Speification Methad [ and Epsilon ,]

1 Turbulent Kinetic Energy (m2/s2)i o s constant -
| Turbulent Dissipation Rate (m2/s3)l 7 4 lcnnsiant V]

Phase Type
mixture velodty-nlet - I
0K Cancel Help
[ Ediit... ] [ Copy... ][Proﬁles‘.. i — =
- . correct the wall distance.

[ Parameters... | [Operating Conditions... | Please select ssolvefinitialize/repair-
d Periodic Conditions. .. using the text user interface to switch
3 alternative algorithm.

........ m

1 Done. [

22


http://www.mhtl.uwaterloo.ca/old/onlinetools/airprop/airprop.html

6.8. Setup > Boundary Conditions > Outlet > Edit... Change the parameters as per below and click
OK. (For inviscid model you do not need to specify turbulence parameters.)
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6.9. Setup > Reference Values. Change parameters as per below. The velocity, temperature, density,
and viscosity should be entered from EFD data.
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7. Solution

7.1. Solution > Solution Methods. Change parameters as per below. (For inviscid case you do not need
to input turbulence parameters.)
C:Viscid Fluent@L-COE211.engin.uiowa.edu [2d, dp, pbns, ske] [ANSYS Academic Teaching Advanced]

File Mesh Define Solve Adapt Surface Display Report Parallel View Help
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7.2. Solution > Solution Controls. Change Parameters as per below. (If you have problems with the
solution converging, you may decrease the Under —Relation Factors.) (For inviscid case you do not
need to specify turbulence parameters.)
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7.3. Solution > Monitors > Residuals —Print, Plot > Edit.... Change the convergence limit to 1e-05
for all five equations and click OK. (For inviscid case you do not need to specify convergence
criterion for turbulence parameters. You only need to specify criterion for three equations.)

g

=
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b

7.4. Solution > Solution Initialization. Change the parameters as per below and click Initialize. (For

inviscid case you do not need to initialize turbulence parameters.)

r
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7.5. Solution > Run Calculation. Change the Number of Iterations to 10000 and click Calculate.

CiViscid Fluent@L-COE211.engin.uiowa.edu !d, dp, pbns, ske] [ANSYS Academic Teaching Advanced]
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Iteration history should look similar to the one below.
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7.6. File > Save Project.
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8. Results

8.1. Plotting and Saving Residual History

Solution > Monitors > Residuals —Print, Plot > Edit... > Plot > OK.

n C:Viscid Fluent@L-COE211.engin.uiowa.edu [2d, dp, pbns, ske] [ANSYS Academic Teaching Advanced]

File Mesh Define Solve Adapt Surface Display Report Parallel View Help

B Epr-d-mesEaasaim-O-ia-B-ATE

Setup
N =63 Solution

Results

|Manitors

% Solution Methods
*_Sglution Controls

itialization

alculation Activities
/ Run Calculation

8 Parameters & Customization

| Monitors

1: Scaled Residuals

Residuals - Print, Plot

=2 = &=

Surface Monitors

Edit... | [Delete

Volume Monitors

it

Convergence Maritars

o
i
m
|;

Convergence Manager...

B

Compute Local Scale

1 = @ @ W wm sm @ am 2w
Residual Monitors | =
Options Equations
[]Print o Console [ contity [1e05 i
V| Plot —— TR TEEEEEEE
o s-velodity 1e-05
Window
= e I =
T B (] (] [ =
Iterations to Plot . 1e-05
1000 @ — L
= epsilon 7l ]| 1e-05 2
Residual Values Convergence Criterion
Iterations to Store Normalize Tterations absolute i
1000 @ =
g g | e
[¥] scale

[Co e ] (o) (oo ) [ )

File > Save Picture... > Save... Make sure the parameters are as per below and click Save...

Name the file CFD Pre-Lab 2 Residual History change the file directory to the CFD Pre-Lab 2
file you created on the H: drive and click OK.
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8.2. Plotting Pressure Coefficient Distribution with CFD and EFD Data
Results > Plots > XY Plot > Set Up... > Load File... Select Pressure-coef-attack0.xy. Change

the parameters as per below and click Plot. Save the picture the same way as you did for

Residual History but in this case, name it CFD Pre-Lab 2 Pressure Coefficient Distribution.

C:Viscid Fluent@L-COE211.enginuiowa.edu [2d, dp, pbns, ske] [ANSYS Aca

File

Mesh Define Solve Adapt Surface Display Report Parallel

View Help I

As-d-@eSEaasainm-O0-in-B-iTeATE

Setup
#-G4F Solution
- Results
) Graphics
(=-FL] Animations
=5 05

& Reports

- Parameters & Customization

Plots

1; Pressure Coefficent

Plots

Histogram
File
Profiles:

Profile Data - Unavailable
Interpolated Data
FFT

XY Plot

Prassure
Coefficient

Sme01
-1Me+M
-1:80k+H0 =
o5 o o o1 o015 o2 o0z o3 0x
Position {m)
SetUp... Salution XY Plat =]
Options lot Direction Axis Function Sep 23, 2015
ep 23,
Node Values X[y TEsSUre... e ANSYS Flusnt Release 16.2 (24, dp, pbns, ske)
Position on X Axis
Coefficient =

[positionon ¥ axis | | ¥ Tg TosgRe Cosaen 7.9957e-08 2.8559¢-06 1.0179e-085 0:40:28 7 ~
[Tl write to File s Emickion| 7.9924e-08 2.8532e-06 1.0170e-85 0:32:22 7
[Jorder Points 2o [precton vector ~fl| 7.9969e-08 2.8505e-06 1.0160e-05 B:25:54 7
= M=) || 7-9936e-08 2.8477e-B6 1.8151e-B5 B:20:43 7
=il 7.9987e-08 2.8451e-06 1.0140e-05 0:16:34 7
| 7ioouse-us 2lsazue-ss 1.0131e-85 6:39:u4 7
i 7.9994e-08 2.8397e-86 1.0120e-85 B:31:47 7
nterior-fid 7.9062e-08 2.8370e-06 1.0112e-05 B:25:26 7
utiet y-velocity k epsilon timezd
purface_body 8.0008e-08 2_8344e-06 1.0101e-05 0:20:20 7
7.9975e-08 2.8317e-06 1.0092e-05 B:16:16 7
Load Fie... 8.0021e-08 2.8200e-05 1.8081e-05 B:30:20 7
7.9980e-08 2.8263e-06 1.0073e-05 0:31:35 7

Free Data §.00350-U8 2.8737c-06 1.00620-05 ©:25:16 7
8.0003e-08 2.8210e-06 1.0053e-05 0:20:12 7

plot i [ Axes.. | [curves..| [ close | [ Hep | mv

‘

8.3. Plotting Contour of Pressure

Results > Graphics and Animations > Contours > Set Up... Change the parameters as per

below and click Display. Save the picture the same way as you did for Residual History but in
this case, name it CFD Pre-Lab 2 Contour of Pressure.
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8.4. Plotting Contour of Velocity Magnitude

Results > Graphics and Animations > Contours > Set Up... Change the parameters as per

below and click Display. Save the picture the same way as you did for Residual History but in
this case, name it CFD Pre-Lab 2 Contour of Velocity Magnitude. Zoom in where you can see
the airfoil clearly and the change in contour levels around the airfoil.
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8.5. Plotting Velocity Vectors at Leading Edge
Results > Graphics and Animations > Vectors > Set Up... Change parameters as per below
and click Display. Save the picture the same way as you did for Residual History but in this
case, name it CFD Pre-Lab 2 Vectors of Velocity at Leading Edge. Zoom in on the leading edge.
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8.6. Plotting Streamlines Close to Airfoil Surface
Results > Graphics and Animations > Contours > Set Up... Change parameters as per below
and click display. Save the picture the same way as you did for Residual History but in this case,

name it CFD Pre-Lab 2 Streamlines Close to Surface. (Note: You may need to adjust the Min
and Max to adjust the flow over the airfoil.)
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8.7. Printing Lift and Drag Coefficients

Results > Reports > Forces > Set Up... Change parameters as per below and click Print. This
prints out the drag force. If you change the X parameter to 0 and the Y parameter to 1, this prints
out the lift force. If you change the X parameter to 1 and the Y parameter to 0, this prints out the
drag force. Save these values on to the CFD Lab 2 report template.
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9. Exercises

Simulation of Turbulent Flow around an Airfoil

You must complete all the following assignments and present results in your CFD Lab 2 reports following
the CFD Lab Report Instructions.

1. Validation using EFD Lab 3 data

(1). Use the same flow conditions as those in your EFD Lab 3, including geometry (chord length,

angle of attack 0) and Setup (Flow properties, inlet velocity). Use k-e model, 2" order scheme,

double precision with iteration number (10000) and convergent limit (1e-05). Run the simulation.

(2). Modify your EFD data of pressure coefficient in ANSYS format (sample EFD data format has

been provided in CFD Lab 1) and import it into ANSY'S Fluent for pressure coefficient distribution

and conduct validation. Also compare the CFD lift coefficient value with EFD data.

e Figures need to be saved: 1. Time history of residuals (residual vs. iteration number); 2.
Pressure coefficient distribution (CFD and EFD), 3. Contour of pressure, 4. Contour of velocity
magnitude, 5. Velocity vectors (show the region that is interesting, such as the separation region
when angle of attack is large or close to the leading edge of the airfoil), and 6. Streamlines close
to airfoil surface.

e Data need to be saved: lift and drag coefficients

2. Inviscid flow simulation
Use the same conditions as those in exercise 1, except choose “inviscid” for “viscous model”, set the
iteration number to be (10000), and convergent limit to be 10°. Conduct the simulation and
compare solutions with viscous flow results in exercise 1.

e Figures need to be saved: 1. Time history of residuals; 2. Pressure coefficient distribution (CFD
only), 3. Contour of pressure, 4. Contour of velocity magnitude, 5. Velocity vectors (show the
same region that your picked in exercise 1), and 6. Streamlines close to airfoil surface.

e Data need to be saved: lift and drag coefficients

3. Questions need to be answered in CFD Lab 2 report:

3.1. Does inviscid flow has boundary layer near the wall? Zoom in the near wall region and describe
the differences of velocity vectors near the airfoil surface for inviscid and viscous flows.

3.2. What are the correct boundary conditions for velocity and pressure at “inlet” and “outlet”.

3.3. What are the values for lift and drag coefficients for inviscid flow around the airfoil? Are they
both zero?

3.4. Where are the highest and lowest locations for pressure and velocity magnitude? Why? Is
pressure constant for inviscid flows around airfoil?

3.5. For turbulent flow around airfoil, try to qualitatively explain why there is a lift force (vertical up)
on an airfoil using the contour plot of pressure or the XY plot of pressure coefficient
distribution.
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