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1. Purpose 

The Purpose of CFD Lab 2 is to simulate turbulent airfoil flows following “CFD process” by an interactive step-by-step approach and conduct verifications ANSYS software. Students will have “hands-on” experiences using ANSYS to conduct verification and validation for lift coefficient and pressure coefficient distributions, including effect of numerical scheme. Students will manually generate the “O” type and “C” type meshes and investigate the effect of domain size and effect of angle of attack on simulation results. Students will analyze the differences between CFD and EFD, analyze possible source of errors, and present results in the CFD Lab report.
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2. Simulation Design

The problem to be solved is that of turbulent flows around a Clark-Y airfoil. Reynolds number is 143,000 based on the inlet velocity and airfoil chord length. The following figures show the illustrations for “C” type and “O” type meshes. (Note: the figures are not in the exact scale as the true size of the domain and airfoil).

Table 1 - Main particulars
	Parameter
	Symbol
	Unit
	O-type
	C-Type

	Chord Length
	C
	m
	0.3048
	0.3048

	Downstream length
	Lo
	m
	-
	12

	Radius
	Rc
	m
	5,4,3,2,1
	5

	Angle of attack
	α
	degree
	0,6
	0



         [image: ]         [image: ]

In CFD Lab2, Boundary conditions for “C” type of meshes will be “inlet”, “outlet”, “symmetry”, and “airfoil”, as described later. Boundary conditions for “O” type of meshes will be “inlet”, “outlet”, and “airfoil”. Uniform flow was specified at inlet. For outlet, zero gradients are fixed for all velocities and pressure is constant. No-slip boundary condition will be used on the “airfoil”. Symmetric boundary condition will be applied on the “symmetry”.  

Table 2 - Grids
	Grid
	Domain
	Radius [m]
	Angle of Attack [degree]

	C
	C-type
	5
	0

	O-fine-R5
	O-type
	
	

	O-medium-R5
	
	
	

	O-course-R5
	
	
	

	O-course-R4
	
	4
	

	O-course-R3
	
	3
	

	O-course-R2
	
	2
	

	O-course-R1
	
	1
	

	O-course-R5-AOA6
	
	5
	6



Table 3 - Simulation Matrix
	Study
	Grid

	Domain size
	O-course-R5, O-course-R4, O-course-R3, O-course-R2, O-course-R1 

	Numerical scheme on V&V
	O-fine-R5, O-medium-R5

	Domain shape
	C

	Angle of attack
	O-course-R5-AOA6



All EFD data for turbulent airfoil flow in this Lab can be downloaded from class website (http://www.engineering.uiowa.edu/~me_160/).


Table 4 - Figures and data sets needed to be saved
	 
	Grid
	Flow
	Convergence Limit
	Figue
	Data

	1
	type=O-Domain-Study-coarse-R=5-aoa=0
	Turbulent
	1.00E-05
	*
	None

	2
	type=O-Domain-Study-coarse-R=4-aoa=0
	Turbulent
	1.00E-05
	None
	None

	3
	type=O-Domain-Study-coarse-R=3-aoa=0
	Turbulent
	1.00E-05
	None
	None

	4
	type=O-Domain-Study-coarse-R=2-aoa=0
	Turbulent
	1.00E-05
	None
	None

	5
	type=O-Domain-Study-coarse-R=1-aoa=0
	Turbulent
	1.00E-05
	None
	None

	6
	type=O-V&V-R=5-aoa=0-fine
	Turbulent
	1.00E-05
	Mesh,V&V Figures, Residuals
	Pressure Coefficient (29 pts)

	7
	type=O-V&V-R=5-aoa=0-medium
	Turbulent
	1.00E-05
	Mesh,V&V Figures
	Pressure Coefficient (29 pts)

	8
	type=O-V&V-R=5-aoa=0-coarse
	Turbulent
	1.00E-05
	Mesh,V&V Figures
	Pressure Coefficient (29 pts)

	9
	type=C-R=5-aoa=0
	Turbulent
	1.00E-05
	Mesh
	Lift Coefficient

	10
	type=O-AOA-Study-coarse-R=5-aoa=6
	Turbulent
	1.00E-05
	*
	Lift and Drag Coefficient

	 

	*
	Pressure Contour, comparison with EFD for pressure coefficient distribution,
velocity vectors near airfoil surface, streamlines near airfoil surface












3. Open ANSYS Workbench and Layout Setup
3.1. Start > All Programs > ANSYS 14.5 > Workbench 14.5
[image: ]
3.2. Toolbox > Component Systems. Drag and drop Mesh and Fluent components to Project Schematic and connect the Mesh to the setup as per below. 
[image: ]
3.3. Right click small down arrow in upper left corner of mesh component and select Rename. Rename the component according the grid and domain size.
[image: ]

4. Mesh Importing
4.1. Right click on Mesh and select Import Mesh File…. 
[image: ]
4.2. Select the O-automatic-course-R5-aoa-0 grid and click Open. 
[image: ]
4.3. The layout file should look as follows, if the checkmark is a lightning bolt, try right clicking imported mesh and select Update.
[image: ]


5. Setup
5.1. Right click Setup and select Edit…
[image: ]
5.2. Select Double Precision and click Ok.
[image: ]
5.3. Click Check and check the output (red box shown below) for any errors.
 [image: ]

5.4. Solution Setup > Models > Viscous – Laminar > Edit… Choose the options below and click Ok.
[image: ]

5.5. Problem Setup > Materials > Fluid > air > Create/Edit. Change Density and Viscosity to experimental values and click Change/Create then click close.
[image: ]
5.6. Solution Setup > Boundary Conditions > inlet > Edit. Change velocity to experimental condition and rest of the parameters to values shown below and click OK.
[image: ]
5.7. Problem Setup > Boundary Conditions > outlet > Edit. Change turbulence parameters to values shown below and click OK.
[image: ]
5.8. Solution Setup > Reference Values. Change reference values to the experimental values.
[image: ]
5.9. Solution > Solution Methods. Change the option as per below.
[image: ]

5.10. Solution > Solution Controls. Change the under-relaxation factors for, momentum, turbulent kinetic energy, and turbulent dissipation rate to the values below. If your solution diverges try reducing under-relaxation factors.
[image: ]

5.11. Solution > Solution Monitors > Residuals – Print, Plot > Edit… Change convergence criterions and click OK.
[image: ]

5.12. Solution > Solution Initialization. Change the velocity to experimental value and rest of the parameters as per below and click Initialize. 
[image: ]
5.13. Solution > Run Calculation. Change number of iterations to 10,000 and click Calculate.
[image: ]
5.14. File> Save Project File> Name “Fluids CFD Lab 2”> Select zip file on H: Drive.
[image: ]
5.15. Close Fluent.

6. Continue Layout
6.1. In the workbench home screen, right click the Fluent bar on the Fluent component and select Duplicate.
[image: ]
6.2. Drag and drop another Mesh component into the Workbench Project Schematic.
[image: ]
6.3. Delete the connection between the original mesh component and the duplicated Fluent component by right clicking the line, selecting Delete, and clicking OK. Then reconnect the new mesh to the duplicated Fluent component. It should look similar to the layout below. 
[image: ]
6.4. The new mesh can then be imported and renamed as per section 4. (Note: This is an efficient way to copy the Fluent setup. This can be done for all the remaining simulations that need to be run. This saves time from having to repeat the setup process for every simulation.)
6.5. The final layout should look similar to the layout below. (You should take a screen shot of your layout and add to the final report.)
[image: ]Simulation for
Angle of Attack Study
Simulation for
C-Domain Study
Simulations for
V&V Study
Simulations for Effects
of Domain Size


7. Continuing Setup
7.1. Right click the duplicated Fluent Setup and click Edit…
[image: ]



7.2. Select Yes.
[image: ]
7.3. Select OK.
[image: ]
7.4. Solution > Solution Initialization > Click Initialize.
[image: ]
7.5. Solution > Run Calculation > Click. (This method can be used for running the remaining simulations.)
7.6. File > Save Project.
[image: ]



8. Post Processing 
Displaying Residuals and Mesh
Solution > Solution Monitors > Residuals – Print, Plot > Edit > Plot.
[image: ]
File > Save Picture. Using option as per below save figure.
[image: ]
Display > Mesh > Display. 
[image: ]
[image: ]
Printing Forces
Results > Forces > Setup > Print. This will print the drag coefficient as per below.
[image: ]
[image: ]
Results > Forces > Set Up… Change the direction vector as per below and click Print. This will print the lift coefficient as per below.
[image: ]
[image: ]
Plotting Results
Results > Plots > XY Plot > Set Up… Select parameter as per below and click Plot.
[image: ]
Click Load File… and load the experimental pressure coefficient then click Plot.
[image: ]
[image: ]
Plotting Contours and Vectors
Results > Graphics and Animations > Graphics > Contours > Setup. Checked filled, select static pressure and click Display.
[image: ]
[image: ]

Results > Graphics and Animations > Graphics > Vectors > Set Up. Click Display.
[image: ]
[image: ]
Results > Graphics and Animations > Graphics > Contours > Set Up… Select parameters as per below and click Display. You can modify min and maximum to get a better figure.
[image: ]
[image: ]


9. C-Domain
9.1. From the Workbench home screen, right click on the C-Domain Study module’s Geometry and select New Geometry.
[image: ]
9.2. Select Meter and click OK.
[image: ]
9.3. File > Import External Geometry File… Select intro-airfoil.igs and click Open. Click Generate.
9.4. Add a new plane by selecting the New Plane button. For the Type select From Point and Normal.
[image: ]

9.5. For the Base Point, zoom in and select the point at the trailing edge as seen below. 
[image: ]
9.6. For the Normal Defined By, select the XYPlane on the Tree Outline. This creates a plane with the origin at the trailing edge point.
[image: ]
9.7. Click Generate.
9.8. Make sure the plane you just created is selected, then click the New Sketch button.
9.9. Sketching > Arc by Center. Draw an arc centered at the trailing edge origin as per below. Make sure the end points are on the y-axis.
[image: ]
9.10. Sketching > Rectangle by 3 Points. Draw a rectangle as per below.
[image: ]
9.11. Dimensions > General. Size the arc and rectangle with a radius of 5m and a width of 5m respectively as seen below.
[image: ]     [image: ]
9.12. Delete the line that makes the left side of the rectangle by selecting it and pressing Delete on the keyboard.
9.13. Concept > Surface from Sketches. Select the sketch you just made click Apply, the click Generate.
9.14. [bookmark: _GoBack]Create > Boolean. Make sure the Operation is set to Subract, for the Target Body select the domain and for the Tool Bodies select the airfoil by selecting the Surface Body under the Tree Outline which corresponds to the airfoil. Click Apply when selecting both bodies and then click Generate.
9.15. Concept > Split Edges. Select the arc and click Apply. Make sure the Fraction is set to 0.5. This splits the edge in half. Click Generate.
9.16. Select the upper half of the arc you just split. Concept > Split Edges. Click Apply and change the Fraction to 0.25. This splits the top arc into two parts with the small piece towards the top of the screen.
9.17. Repeat step 9.16 for the bottom piece of the arc you originally split but this time change the Fraction to 0.75. This will split the arc with the smaller piece towards the bottom of the screen.
9.18. Split the vertical line from the rectangle in half as well.
9.19. Use the Line From Points in the Concept drop down menu to draw lines from the domain perimeter to the perimeter of the airfoil always starting from the domain and ending at the airfoil. Do this by selecting the point on the domain, hold Ctrl and select the point on the airfoil. Click Apply and then Generate. Repeat this process to create all the lines shown below. 
[image: ]
9.20. Tools > Projection. Select all the lines you just created by holding Ctrl while selecting them and then click Apply. For the Target select the surface of the domain and click Apply. Click Generate. This splits the domain into six sections as seen below.
[image: ]
9.21. File > Save Project. Close window..
9.22. From the Workbench home screen right click on Mesh and select Edit…
9.23. Right click on mesh > Insert > Mapped Face Meshing. Select all six surfaces and click Apply.
9.24. Right click on Mesh > Insert > Sizing. Selct lines below and click Apply. Change parameters as per below.
[image: ]
9.25. Right click on Mesh > Insert > Sizing. Selct the  line below and click Apply. Change parameters as per below.
[image: ]
9.26. Right click on Mesh > Insert > Sizing. Selct the  line below and click Apply. Change parameters as per below.
[image: ]
9.27. Right click on Mesh > Insert > Sizing. Selct the  lines below and click Apply. Change parameters as per below.
[image: ]
9.28. Right click on Mesh > Insert > Sizing. Selct the  line below and click Apply. Change parameters as per below.
[image: ]
9.29. Right click on Mesh > Insert > Sizing. Selct the  lines below and click Apply. Change parameters as per below.
[image: ]
9.30. Right click on Mesh > Insert > Sizing. Selct the  lines below and click Apply. Change parameters as per below.
[image: ]
9.31. Right click on Mesh > Insert > Sizing. Selct the  lines below and click Apply. Change parameters as per below.
[image: ]
9.32. Right click on Mesh > Insert > Sizing. Selct the  line below and click Apply. Change parameters as per below.
[image: ]
9.33. Right click on Mesh > Insert > Sizing. Selct the  line below and click Apply. Change parameters as per below.
[image: ]
9.34. Click on Mesh and under the Details of “Mesh” change the Physics Preference from Mechanical to CFD. Click Generate.
9.35. Select all the parts that make up the arc by holding down Ctrl and selecting them individually. Right click the selection and select Create Named Selection. Name this inlet.
9.36. Select the vertical line on the right side of the domain, right click it and Create Named Selection. Name this outlet.
9.37. Select the six faces and right click them, select Create Named Selections. Name them fluid.
9.38. Select the four curve that make the airfoil, right click and create named selections. Name them airfoil.
9.39. File > Save Project. Close Meshing window.
9.40. Repeat the steps used in other simulations for all remaining steps of CFD Process.




10. Verification and Validation (V&V Simulations Only)
10.1. From the workbench home screen, right click on the Fluent Solution and from the dropdown menu select edit…
10.2. Select File >  Read > Journal…
[image: ]
10.3. Browse to the zip folder for lab 2, change Files of Type to All Files and select Final Lab 2 29 pt Journal and click ok.

[image: ]
10.4. Click No. (To make sure the points were implemented properly, display the mesh and zoom in to count and verify there are 29 points on the airfoil surface as per below.)
[image: ]
[image: ]

10.5. Results > Plots > XY Plot > Setup... Select parameters as per below, make sure to select points 1 through 29, and click Write. Name the file for future reference. (This only needs to be done for coarse, medium, and fine manual grids, which are used for V&V calculations. It is not needed for automatic grids.)
[image: ]

10.6. Open the V&V Excel template from the zip file.
10.7. Copy and paste the pressure coefficients into the proper sheet corresponding to the grid size. To do this open the saved coefficient data in TextPad, use the “Ctrl + a” function to select all, then right click and select copy. 
[image: ]
10.8. Paste this data into cell A1 of the corresponding pressure coefficient tab. Right click on cell A1 and select Keep Text Only. The cells to the right should auto populate extracting the correct data from the pasted data. If all the x coordinate cells are not green, there was an error in the pasting of the copied data.
[image: ]
10.9. Repeat these steps for the remaining grid sizes. 
10.10. Once all the data is pasted into the three Press Coeff tabs, the V&V Velocity tab auto populates and calculates V&V values.
10.11. Open the Verification Lift Coef tab and input values from y force report into the cells corresponding to the grid size. The V&V values auto calculate
11. Exercises
You need to complete the following assignments and present results in your lab report following the lab report instructions
Verification and Validation of Turbulent Flow around a Clark-Y Airfoil

11.1. Effect of domain size: Run 5 simulations using five different domain sizes using grids O-course-R5, O-course-R4, O-course-R3, O-course-R2 and O-course-R1. Fill the table with lift coefficient with their relative difference between two successive meshes. If the relative change between two successive domain sizes should be less than 1%, then which domain sizes will be enough large to make the CFD simulation results to be independent of the domain size? 
	Circle radius (m)
	1
	2
	3
	4
	5

	Lift Coefficient
	
	
	
	
	

	Relative change
	N/A
	(               )%
	(                )%
	(               )%
	(              )%


· Figures to be saved: None.
· Data to be saved: the above table with values.

11.2. Effect of numerical scheme on Verification study for lift coefficient and validation of pressure coefficient: 
Use “O” type geometry with 0 degree angle of attack. For this exercise only, find one partner in the class to form a group, one student will run V&V using first order upwind scheme, the other will use 2nd order upwind scheme. Then, you must borrow the figures/data from the other student and present in your lab report. 
Based on verification results for lift coefficient, which numerical scheme is closer to the asymptotic range? Which numerical scheme has a lower grid uncertainty? Discuss the validation figure. For which locations of 29 points the CFD simulation has been validated? For which locations the CFD simulation has not been validated? For iterative history of lift coefficient, what is the minimum iteration number for you to determine the lift coefficient has converged to a “constant” value?
· Figures to be saved (only for the numerical scheme you used, but you must also present the figures for the calculations from your partner): 1. The “O” mesh you imported. 2. “Mesh Convergence” panel and “Verification” panel for lift coefficient. 3. Validation figures for pressure coefficient. 4. Iterative history for lift coefficients on fine mesh.
· Data to be saved: None.

11.3. “C” mesh generation: Use “C” type domain and zero degree angle of attack for geometry and use the following parameters for mesh generation. Other parameters are the same as the values in the instruction part. 
· Figures to be saved: “C” mesh generated by yourself.
· Data to be saved: converged lift coefficient.


11.4. Effect of angle of attack on airfoil flow: Using “O”, automatic “coarse” meshes, run two simulations using angle of attack 0 degrees and 6 degrees, respectively. Analyze the difference of flow fields. Which case has a higher lift coefficient, which has a higher drag coefficient?
· Figures to be saved (for both attack angles): 1. pressure contours, 2. comparisons with EFD on pressure coefficient distribution, 3. velocity vectors near airfoil surface, 4. streamlines near the airfoil surface.
· Data need to be saved (for both attack angles): lift and drag coefficients.

11.5. Questions need to be answered when writing CFD report:
11.5.1. Answer all the questions in exercises 1 to 4
11.5.2. Analyze the difference between CFD/EFD and possible error sources.
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